Introduksjon

Velkommen til DAKAT

Datakatalogen for NVDB

Hva er nytt i denne versjonen av DAKAT

Endringer og feilrettinger

Hvordan få hjelp

Hvordan komme i gang med å bruke DAKAT

Fargekoder

En del av funksjonene i programmet er kun tilgjengelig for de som har skriverettigheter. Menyvalg du ikke har tilgang til vil være grået ut.

Tips for bruk av hjelpeteksten

Øverst til venstre under overskriften på hver side i hjelpeteksten vises hvor i hjelpeteksten du står. For å gå et eller flere trinn tilbake klikker du på et av ordene i denne strengen

Eksempel på overskrift for en side i hjelpeteksten.

For å gå et trinn tilbake - Klikk på Rapporter

For å gå to trinn tilbake - Klikk på Utskrift

For å gå tre trinn tilbake - klikk på Fil

Denne hjelpeteksten er laget av Vilhelm Børnes - Statens vegvesen, Ola Martin Rennemo - SINTEF og Tore Paulsen - Norconsult.

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation

Copyright © 2013-2014 by Statens Vegvesen. All Rights Reserved.


Hva er nytt i denne versjonen av DAKAT

Introduksjon ››

Nytt i denne versjonen

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Endringer og feilrettinger

Introduksjon ››

Endringer

Feilrettinger

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Hvordan få hjelp

Introduksjon ››

Vegdirektoratet seksjon NVDB og Geodata er eier og har brukerstøtte for dette programmet.

Kontaktperson Datakatalogen: Vilhelm Børnes vilhelm.bornes@vegvesen.no Telefon 932 43 269

Kontaktperson : Produktspesifikasjoner, kvalitetskontroll, bruksområder : Hilde Øfsti, hilde.ofsti@vegvesen.no 412 98 908

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Installasjon og oppstart

Det er ingen egen installasjon for DAKAT. Ved første gangs oppstart vil programmet installere seg selv.

Systemkrav

Oppstart av programmet

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Systemkrav

Installasjon og oppstart ››

Programmet startes fra en nettleser, men kjører som en Java-applikasjon. Du bør til enhver tid sørge for å ha nyeste versjon av Java installert på PC'en.

DAKAT stiller ikke stor kra til maskinvaren og kan derfor kjøres på de fleste PC'er av rimelig ny dato.

Programmet kjører på Windows Vista og Windows 7.

Port 8080 må være åpen for utgående trafikk. Dette er vanligvis tilfelle.

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Oppstart av programmet

Installasjon og oppstart ››

Programmet startes fra denne adressen: http://kunder.runit.no/vegvesen/datakatalog/

Når adressen velges kommer dette skjermbildet opp:

Oppstartsskjermbilde for NVDB Datakatalog

For all normal bruk velges siste offisielle versjon som markert i øverste skjermbildet over.

Noen ganger kan det være aktuelt å se på hva som kommer i neste versjon. Da velger du Neste Dakatversjon.

For en del spesielle tilfeller som f.eks. overføring av ProKat base eller bilder må du starte nederste valg Neste Dakat versjon med innlogging. For å bruke denne må du ha brukernavn og passord.

DAKAT finnes også som en ren PC-versjon.

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Innhold i hovedskjermbildet

Oversikt Valg av Tema Se på innhold i Datakatalogen Listemodus Trestrukturmodus

Oversikt over hovedskjermbildet

Hovedskjermbildet i DAKAT gir en oversikt over innholdet i Datakatalogen, og består av deler som vist her:

Innhold i hovedskjermbildet

Du finner forklaring til hver del her:

Versjonsnummer

Menylinje

SVV Logo

Infoknapp

Temavalg

Verktøylinje

Infotekst

Lister

Sammenhenger

Alle

Skjermbildet kan opptre både i Listemodus og i Trestrukturmodus . Funksjonaliteten i skjermbildet er i prinsippet den samme i begge moduser. Denne veiledningen tar utgangspunkt i Datakatalogen i Listemodus.

Datakatalogen er bygd opp av flere nivå. En beskrivelse av alle nivåene finner du her .

Valg av Tema

På øverste nivå er 8 forskjellig tema:

Flervalgsboks for tema

Her velger du et tema som passer for den type jobbing du ønsker å gjøre. Temaet må da inneholde de vegobjekttyper kategorier du vil jobbe med.

Hovedinndeling som vist her inneholder alt.

Mer om valg av tema finner du her

Hvert tema er delt inn i flere vegobjekttype kategorier. På nivåene under finnes deretter vegobjekttype, egenskapstype og tillatte verdier. De ulike nivåene er plassert i listeform i hovedskjermbildet.

Se på innhold i Datakatalogen

Velg en av lenkende under for forklaring til de forskjellige deler av innholdet i Datakatalogen

Valg av Tema

Vegobjekttypekategori

Vegobjekttype

Egenskapstype

Tillatte verdier

Tillatt sammenheng

Listemodus

Hovedskjermbildet i DAKAT

I listemodus velger du deg fram til det du ønsker å se på. Du starter med å velge Vegobjekttype kategori. Kategorien Alle vil gi deg alle vegobjekttyper.

Klikker du en gang i liste for Vegobjekttype kategori vil neste nivå som er Vegobjekttype åpnes. Infoteksten for valgt Vegobjekttype kategori vil vises. Dersom du dobbeltklikker vil det også åpne seg et detaljskjermbilde for Vegobjekttype kategori.

Du kan nå velge Vegobjekttype i neste liste. Klikker du en gang vil neste nivå som er Egenskapstype åpnes. Infoteksten for valgt Vegobjekttype vil vises. Dersom du dobbeltklikker vil det også åpne seg et detaljskjermbilde for Vegobjekttype.

Du kan nå velge Egenskapstype i neste liste. Klikker du en gang vil neste nivå som er Tillatte verdier åpnes. Infoteksten for valgt Egenskapstype vil vises. Dersom du dobbeltklikker vil det også åpne seg et detaljskjermbilde for Egenskapstype

Du kan nå velge Tillatte verdier i neste liste. Klikker du en gang vil Infoteksten for valgt Tillatt verdi vil vises. Dersom du dobbeltklikker vil det også åpne seg et detaljskjermbilde for T illatt verdi

Verktøylinje

For beskrivelse av Verktøylinje se her

Trestrukturmodus

For å vise innholdet i trestruktur velger du knappen som er markert i utklippet fra verktøylinja her:

Skjermbilde av Datakatalogen med ”trestrukturvisning

Bruk av trestrukturmodus fungerer svært lik bruken av listemodus. Øverste nivå viser Tema, nivå 2 viser Vegobjekttypekategori, nivå 3 viser Vegobjekttype og nivå 4 viser Egenskapstype.

Klikk en gang på en linje for å aktivisere den. Dersom denne inneholder undernivåer vil det komme et [image] -tegn foran linjen. Klikk på [image] -tegnet for å åpne neste nivå.
-tegnet skifter til et [image] -tegn. Klikk på dette for å lukke et nivå.

Dobbeltklikk på en linje for å åpne neste nivå, samt et detaljbilde for valgt linje.

Verktøylinje

Også trestrukturmodus har Verktøylinje:

Denne knappen åpner detaljbilde for valgt linje.

Denne knappen viser logg for endringer i Datakatalogen.

Denne knappen bytter til listemodus

Disse knappene har ingen funksjon i trestrukturmodus

Oversikt Valg av Tema Listemodus Trestrukturmodus

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Inndeling av hovedskjermbildet

Innhold i hovedskjermbildet ››

Her kommer en kortfattet forklaring til alle deler av hovedskjermbildet, med mer detaljerte forklaringer ved å klikke på hvert emne:

Innhold i hovedskjermbildet

Versjonsnummer Gjeldende versjonsnummer for datakatalogen

Menylinje Linje med menyvalg for betjening av programmet

SVV Logo Link til informasjon om NVDB

Infoknapp Informasjon om ansvarlige for programmet

Temavalg Flervalgsboks for valg av tema

Infotekst Infotekst om det feltet som til enhver tid er valgt

Lister Seksjon med lister for å velge seg fram til ønsket element

Sammenhenger Seksjon som viser sammenhenger mellom aktiv vegobjekttype og andre vegobjekttyper

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Versjonsnummer

Innhold i hovedskjermbildet ›› Inndeling av hovedskjermbildet ››

Info om versjon

Øverst i skjermbildet vises det hvilken versjon av Datakatalogen som benyttes. I eksemplet under er det brukt versjon 1.91 av Datakatalogen.

Eksempel som viser versjonsnummer for Datakatalogen (1.91)

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Menylinje

Innhold i hovedskjermbildet ›› Inndeling av hovedskjermbildet ››

Menylinjen gir deg 6 forskjellige menyer, som igjen har flere menyvalg.

Fil - Inneholder valg for import, eksport og utskrift

Data - Inneholder menyvalg for å se på og redigere innhold i Datakatalogen

Oppsett - Inneholder en del spesielle funksjoner for oppsett av programmet

Verktøy - Inneholder funksjoner for kontroll og vedlikehold av Datakatalogen

Vindu - Bytter mellom listemodus og trestrukturmodus

Hjelp - Gir denne hjelpeteksten, samt en symbolforklaring

All redigering, samt en del menyvalg er kun tilgjengelig dersom du har rettigheter for oppdatering av Datakatalogen.

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


SVV Logo

Innhold i hovedskjermbildet ›› Inndeling av hovedskjermbildet ››

Ved å klikke på logoen [image] til Statens vegvesen vil det åpnes en link til en infoside om NVDB:

Del av infoside for NVDB

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Infoknappen

Innhold i hovedskjermbildet ›› Inndeling av hovedskjermbildet ››

Knappen med [image] gir info om hvem som er ansvarlig for utvikling av og brukerstøtte til DAKAT:

Resultat ved bruk av infoknappen

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Temavalg

Innhold i hovedskjermbildet ›› Inndeling av hovedskjermbildet ››

Dette er en flervalgsboks som inneholder valg av tema.

Figuren viser flervalgsboksen for valg av Tema.

Tema vil gruppere vegobjekttypene på en måte som er spesielt egnet til bestemte typer bruk av Datakatalogen.

Dette gjøres ved at det aktuelle tema inneholder bare vegobjekttyper som er aktuelle for denne typen jobbing.

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Infotekst

Innhold i hovedskjermbildet ›› Inndeling av hovedskjermbildet ››

Infoteksten øverst midt på skjermbildet viser:

  • ID-nummer
  • Navn
  • Beskrivelse

på den kategorien, vegobjekttypen, egenskapstypen eller tillatte verdien som er markert.

Et eksempel på en infotekst er vist i her:

Eksempel på infotekst.

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Lister

Innhold i hovedskjermbildet ›› Inndeling av hovedskjermbildet ››

Denne delen inneholder lister med innhold i datakatalogen.

Ved bruk av disse listene kan du velge deg fram til akkurat den delen av Datakatalogen du vil se på og eventuelt endre om du har rettigheter for det.

Du velger deg fram til riktig del ved å starte med listen til venstre, velge et av valgene der og så gå et trinn mot høyre og velge inntil du har fått fram det du ønsker.

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


Sammenhenger

Innhold i hovedskjermbildet ›› Inndeling av hovedskjermbildet ››

I denne delen kan du se på sammenhenger (assosiasjoner) mellom vegobjekttypene:

Figuren viser assosiasjoner for Tunnelløp uten trafikk

Mange objekttyper vil ha en relasjon til andre objekttyper, og disse vil du se her.

Sammenhengene vil være av typen:

  • En vegobjekttype kan ha/inneholde objekter av en annen vegobjekttype
  • En vegobjekttype kan tilhøre/ligge i en annen vegobjekttype

Eksempler på dette:

  • En rasteplass kan ha Lekeapparat og Toalettanlegg
  • Toalettanlegg kan ligge på Rasteplass eller Ferjeleie
  • Et tunnelløp kan inneholde Signalanlegg, Ventilasjonsanlegg, Nødtelefon osv.
  • Nødtelefon kan finnes i Tunnelløp og Nødstasjon

Det finnes en rekke lovlige typer sammenhenger .

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Tema

Innhold i hovedskjermbildet ››

Nedtrekkslisten øverst til venstre i hovedskjermbildet viser hvilket Tema som er valgt. Det kan velges mellom 8 ulike tema:

Nedtrekksliste med mulige valg for Tema

Dersom du velger Tema fra Data-menyen kommer et detaljskjermbilde for tema opp:

Detaljskjermbilde for tema

Her kan du se kortnavn og forklaring til en del av valgene.

Meny

Øverst i skjermbildet er det en meny med følgende funksjoner:

Fil

Utskrift - Skriver ut innholdet i skjermbildet

Editer

Editer - Slår på redigering

Hjelp

Hjelp - Viser denne hjelpeteksten

Editer-knappen vil ikke være tilgjengelig medmindre du har rettigheter for redigering

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom Vegobjekttypekategorier

Verktøylinjen har følgende funksjoner:

Gå til første forekomst

Gå til forrige forekomst

Gå til neste forekomst

Gå til siste forekomst

Knappen har ingen funksjon her

Knappen har ingen funksjon her

Knappen har ingen funksjon her

Kun knappene for å bla fram og tilbake vil være aktiv om du ikke har rettigheter for redigering.

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Vegobjekttypekategori

Innhold i hovedskjermbildet ››

Oversikt Meny Verktøylinje Innhold i feltene

Oversikt

Liste som viser hvilke Vegobjekttypekategorier som finnes innenfor valgt Tema.

Ved å dobbeltklikke på en forekomst i listen for Vegobjekttypekategorier, eller klikke på en forekomst og trykke [image] blir detaljskjermbildet i figuren under vist.

Detaljskjermbilde av vegobjekttype kategori.

Meny

Øverst i skjermbildet er det en meny med følgende funksjoner:

Fil

Utskrift - Skriver ut innholdet i skjermbildet

Editer

Editer - Slår på redigering

Hjelp

Hjelp - Viser denne hjelpeteksten

Editer-knappen vil ikke være tilgjengelig medmindre du har rettigheter for redigering

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom Vegobjekttypekategorier

Verktøylinjen har følgende funksjoner:

Gå til første forekomst

Gå til forrige forekomst

Gå til neste forekomst

Gå til siste forekomst

Opprett ny forekomst

Slett forekomst

Lagre endringer

Kun knappene for å bla fram og tilbake vil være aktiv om du ikke har rettigheter for redigering.

Innhold i feltene

Feltene i skjermbildet viser informasjon om den valgte Vegobjekttypekategorien:

ID Angir identitet til Vegobjekttypekategori

Navn Angir navn til Vegobjekttypekategori.

Kortnavn Angir kortnavn til Vegobjekttypekategori

Sorteringsnr Angir sorteringsnummer. Kan benyttes for å sortere Vegobjekttypekategori i spesiell rekkefølge.

Inngår i tema Gir referanse til tema som Vegobjekttypekategori tilhører.

Beskrivelse Angir beskrivelse til Vegobjekttypekategori.

Tilhørende typer Viser aller Vegobjekttyper som inngår i valgt Vegobjekttypekategori

Hvis du klikker på en av vegobjekttypene i listen Tilhørende typer vil denne åpnes i hovedskjermbildet.

Hvis du dobbeltklikker på en av vegobjekttypene i listen Tilhørende typer vil detaljskjermbildet til denne åpnes.

Oversikt Meny Verktøylinje Innhold i feltene

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Vegobjekttype

Innhold i hovedskjermbildet ››

Oversikt Meny Verktøylinje Innhold i feltene Styringsparametere

Oversikt

Liste som viser hvilke Vegobjekttyper som finnes innenfor valgt Vegobjekttypekategori.

Ved å dobbeltklikke på en forekomst i lista, eller klikke på en forekomst og trykke [image] blir detaljskjermbildet vist:

Detaljskjermbilde av vegobjekttype

Meny

Øverst i skjermbildet er det en meny med følgende funksjoner:

Fil

Utskrift - Skriver ut innholdet i skjermbildet

Editer

Editer - Slår på redigering

Hjelp

Hjelp - Viser denne hjelpeteksten

Editer-knappen vil ikke være tilgjengelig medmindre du har rettigheter for redigering

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom Vegobjekttyper

Verktøylinjen har følgende funksjoner:

Gå til første forekomst

Gå til forrige forekomst

Gå til neste forekomst

Gå til siste forekomst

Opprett ny forekomst

Slett forekomst

Lagre endringer

Kun knappene for å bla fram og tilbake vil være aktiv om du ikke har rettigheter for redigering.

Utskriftsmeny

Utskriftsmeny

Denne menyen brukes for spesielle utskrifter og rapporter.

Viser logg over endringer som gjelder denne vegobjekttypen

Lager rapport over bruksområder og behov for denne vegobjekttypen

Lager rapport med kvalitetskrav for denne vegobjekttypen

Lager kvalitetskontrollskjema for denne vegobjekttypen

Lager rapport med produktspesifikasjon for denne vegobjekttypen

Innhold i feltene

Feltene i skjermbildet viser informasjon om den valgte Vegobjekttypekategorien:

ID Angir identitet til Vegobjekttype

Navn Angir navn til Vegobjekttype

Inngår i kategori Angir hvilken Vegobjekttypekategori Vegobjekttypen inngår i

Hovedkategori Angir hvilken hovedkategori Vegobjekttypen tilhører.

Arver fra Angir objekttype som gitt Vegobjekttype arver fra.

Stedfesting Angir hvilken type vegnettstilknytning vegobjektene skal ha.

Lovlige verdier:
punkt Vegobjekttypen stedfestes i et punkt
strekning Vegobjekttypen stedfestes i en linje
flerepunkt Vegobjekttypen stedfestes i flere punkter
ingen Vegobjekttypen har ingen stedfesting

Kortnavn Angir kortnavn til Vegobjekttypen.

SOSINVDB-navn Angir navn for vegobjekttypen i SOSI NVDB standarden

Sortering objektliste Angir nummer til Vegobjekttypen. Kan benyttes f.eks. til sortering.

Dato fra NVDB Angir dato Vegobjekttypen ble gyldig for bruk i NVDB. I praksis ble den gyldig i første versjon etter denne dato.

Dato fra objektliste Angir dato Vegobjekttypen ble gyldig for bruk i objektlista. I praksis ble den gyldig i første versjon etter denne dato.

Status Angir hvilken status Vegobjekttypen har.

Lovlige verdier:

NVDB, ok - Vegobjekttypen er aktivert i NVDB
NVDB, til revisjon - Vegobjekttypen er til revisjon i NVDB

NVDB, test - Vegobjekttypen er laget for testing

På vent - Vegobjekttypen er klar, men ikke aktivert i NVDB

Til vurdering - Vegobjekttypen til vurdering for innføring i NVDB

Uaktuell nå - Vegobjekttypen er for øyeblikket ikke aktuell i NVDB

Historisk - Vegobjekttypen er utgått i NVDB, men tas vare på av historiske årsaker

Lokal bruk, innsjekk ulovlig - Brukes bare for lokal test og utprøving. Skal ikke sjekkes inn.

Beskrivelse Angir beskrivelse til Vegobjekttypen.

Veiledning registrering Gir veiledning om hvordan data skal legges inn.

Tilhørende egenskapstyper Liste som viser alle egenskapstypene som inngår i vegobjekttypen

Styringsparametere

Styringsparametere er tilleggsinformasjon for en vegobjekttype som bestemmer hvordan vegobjekttypen skal forholde seg til en del faste egenskaper, oppførsel og relasjoner som gjelder mange vegobjekttyper.

Overlapp Angir om det kan være to eller flere forekomster av denne vegobjekttypen med overlappende vegident (vegident inkluderer eventuelt sideposisjon og feltkode). Gjelder strekningsobjekter

Lovlige verdier:

Valgt - Overlapp OK

Ikke valgt - Overlapp ikke OK

Kjørefelt relevant Angir hvorvidt det er relevant å angi kjørefeltkode for denne vegobjekttypen

Lovlige verdier:

Nei - Kan ikke gi kjørefeltkode
Kan - Kan gi kjørefeltkode
Må - Må gi kjørefeltkode

Sidepos. relevant Angir hvorvidt "sideposisjonskode" (H, V, M, HT, VT osv.) skal kunne være en del av vegobjektenes vegnettstilknytning.

Lovlige verdier:

Nei - Kan ikke gi sideposisjon

Kan - Kan gi sideposisjon
Må - Må gi sideposisjon

Høyde relevant Angir hvorvidt "høydenivåkode" (over, under, på) skal kunne være en del av vegobjektenes vegnettstilknytning.

Lovlige verdier:

J - Kan gi høydenivåkode

N - Kan ikke gi høydenivåkode

Tidsrom relevant Angir om vegobjektene normalt har en gyldighetsperiode på operativt vegnett.

Lovlige verdier:

J - Kan gi tidsrom
N - Kan ikke gi tidsrom

Retning relevant Angir hvorvidt det kan være egenskapsverdier tilknyttet vegobjektene som beregnes som funksjon av utstrekning og metreringsretning.

Lovlige verdier:

J - Kan gi retning
N - Kan ikke gi retning

Flyttbar Angir hvorvidt vegobjekter gitt for vegtrasenivå også er gyldig for kjørefeltnivå.

Lovlige verdier:

J - Flyttbar Eks. Fart og dekke

N - Ikke flyttbar Eks. ÅDT

Sek type2 Ok Angir hvorvidt det er lov å knytte vegobjekter til sekundærtype 2 og konekteringslenker.

Lovlige verdier:

J - OK
N - Ikke OK

Abstrakt objekttype Angir om vegobjekttype er abstrakt eller ikke.

Lovlige verdier:

J - Abstrakt
N - Ikke abstrakt

Filtrering Angir om det skal være mulig å stille krav til denne Vegobjekttypen i HVOR-dialogen. Normalt bare relevant for Vegobjekttyper av type strekning.

Lovlige verdier:

J - Filtrering OK
N - Ingen filtrering

Avledet Angir om Vegobjekttypen i sin helhet er avledet. Dvs. alle egenskapsverdier er avledet.

Lovlige verdier:

J - Avledet Eks. Vegobjekttyper som har statistikkinformasjon
N - Ikke avledet

Må ha mor Angir hvorvidt vegobjektene må være tilknyttet et "mor-objekt" for å kunne eksistere (dvs. hvert vegobjekt (B) må ha sammenheng til annet vegobjekt (A)).

Lovlige verdier:

J - Må ha mor
N - Må ikke ha mor

Dataserie Angir hvorvidt vegobjektene normalt har en serie med andre (måle) dataobjekt koplet mot seg.

Lovlige verdier:

J - Dataserie Ja skal bare gi hvis det er assosiasjon fra (måle)dataobjekt til dataserieobjektet.
N - Ikke dataserie

Ajourhold i Angir om vegobjektene skal overleve ved et fysisk tiltak på vegen som gir I-status (ny senterlinje ligger innenfor gamle kantlinjer).

Lovlige verdier:

Overlever ikke
Overlever
Ikke tatt stilling

Ajourhold splitt Angir om vegobjektene kan splittes uten at det får konsekvenser for egenskapsverdiene. Problematisk hvis Vegobjekttypen har summariske Egenskapstyper eller hvis det er vegobjekt med egennavn.

Lovlige verdier:

Kan ikke splittes
Kan splittes
Ikke tatt stilling

Suppleringslengde I forbindelse med omlegging av veg, f.eks. utretting av en sving, angis det her maks lengde for når identisk informasjon i hver ende automatisk skal legges på nyvegen ved NVDB-ajourhold. Kun strekningsobjekter.

Lovlige verdier:

0 - Uaktuelt
>0 - krever at ajh_splitt=1

Dekningsgrad Eksisterende forekomster blir automatisk splittet ved overlapping med nye. Angir at vegobjekt av denne objekttype skal splittes.

Lovlige verdier:

x eller annet tegn - Ja
tomt felt - Nei

Oversikt Meny Verktøylinje Innhold i feltene Styringsparametere

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Egenskapstype

Innhold i hovedskjermbildet ››

Oversikt Meny Verktøylinje Innhold i feltene Styringsparametere

Oversikt

Liste som viser hvilke Egenskapstyper som finnes for valgt Vegobjekttype. Egenskapstyper er også beskrevet i her .

Ved å dobbeltklikke på en forekomst i lista, eller klikke på en forekomst og trykke [image] blir detaljskjermbildet vist:

Detaljskjermbilde av egenskapstype

Meny

Øverst i skjermbildet er det en meny med følgende funksjoner:

Fil

Utskrift - Skriver ut innholdet i skjermbildet

Editer

Editer - Slår på redigering

Hjelp

Hjelp - Viser denne hjelpeteksten

Editer-knappen vil ikke være tilgjengelig medmindre du har rettigheter for redigering

Verktøylinje

Under menyen har vi en Verktøylinje der man kan bla mellom Vegobjekttyper

Verktøylinjen har følgende funksjoner:

Gå til første forekomst

Gå til forrige forekomst

Gå til neste forekomst

Gå til siste forekomst

Opprett ny forekomst

Slett forekomst

Lagre endringer

Kun knappene for å bla fram og tilbake vil være aktiv om du ikke har rettigheter for redigering.

Innhold i feltene

ID Angir identitet til Egenskapstypen

Navn Angir navn til Egenskapstypen.

Viktighet Angir eventuelle krav til registrering for denne Egenskapstypen

Lovlige verdier:

1: Påkrevd, absolutt krav - Egenskapstypen er påkrevd i databasen og må alltid gis for at lagring tillates

2: Påkrevd, ikke absolutt - Egenskapstypen er påkrevd og må alltid gis for at objektet er å anse som ferdig registrert. Kan lagres midlertidig uten.
3: Betinget, se "Merknad registrering" - Egenskapstypen skal registreres dersom gitte forutsetninger er til stede. Kan ellers utelates. Betingelse er beskrevet i feltet Merknad registrering
4: Opsjonell - Det er frivillig å registrere denne egenskapstypen
7: Mindre viktig - Egenskapstypen vil utgå på sikt. Registrering er frivillig
9: Historisk, oppdateres ikke - Egenskapstypen er kun definert av historisk interesse. Det skal ikke registreres nye data for denne egenskapstypen.

Vegobjekttype Gir relasjon til vegobjekttype som Egenskapstypen gjelder for.

Egenskapskategori Gir relasjon til egenskapskategori som Egenskapstypen tilhører.

Lovlige verdier

Del av egenskapstype Gir relasjon til Egenskapstypen som denne Egenskapstypen er del av (har som superegenskapstype). Benyttes i forbindelse med Datatype "struktur" (sammensatte Egenskapstyper).

Kortnavn Angir kortnavn til Egenskapstypen.

SOSINVDB-navn Angir navn for egenskapstypen i SOSI NVDB standarden

Sorteringsnr Angir sorteringsnummer. Kan benyttes for å sortere Egenskapstypen tilhørende en bestemt Vegobjekttype.

Datatype Gir relasjon til datatype som Egenskapstypen er av.

Lovlige verdier

Enhet Gir relasjon til enhet som Egenskapstypen er av.

Lovlige verdier

Total feltlengde Angir hvor langt datafelt som skal settes av. Inkluderer evt. komma og desimaler.

Desimaler Angir hvor mange desimaler som kan benyttes.

Antall verdier Angir hvor mange verdier det er lov å kople til Egenskapstypen for et vegobjekt. Standard = 1.

Feltmønster Angir feltmønster eller maske for et datafelt. F.eks. ååååmmdd for dato.

Dato fra NVDB Angir dato Egenskapstypen ble gyldig i NVDB

Dato fra objektliste Angir dato Egenskapstypen ble gyldig i objektlista.

OCL-streng Angir beskrankninger knyttet til Egenskapstypen verdiområde. Beskrives vha OCL-syntaks.

Ledetekst Angir tekst som skal benyttes til ledetekst i VegReg.

Beskrivelse Gir beskrivelse av Egenskapstypen.

Merknad registrering Angir en tekst som skal være til hjelp under registrering. For geometrityper gis her hvor på objektet koordinater skal registreres.

Tillatte verdier Her gis en liste med Tillatte verdier egenskapstypen kan ha. Gjelder kun for de egenskapstyper der dette er aktuelt.

Defaultverdi Angir verdi som skal gis som forslag til verdi ved innlegging av data.

Minverdi Gir rimelig minverdi. Hvis det blir gitt inn lavere verdi må det gis melding til bruker.

Maksverdi Gir rimelig maksverdi. Hvis det blir gitt inn høyere verdi må det gis melding til bruker.

Absolutt Minverdi Angir absolutt grense for minimumsverdi. Skal bare gis hvis avvik fra det feltlengde og antall desimaler tillater.

Absolutt Maksverdi Angir absolutt grense for maksimumsverdi. Skal bare gis hvis avvik fra det feltlengde og antall desimaler tillater.

Styringsparametere

Skal ha verdi Angir hvorvidt det må gis verdi til denne Egenskapstypen for et vegobjekt.

Lovlige verdier:

J - Det kreves verdi til denne Egenskapstypen

N - Det kreves ikke verdi til denne Egenskapstypen

Indekseres Angir hvorvidt Egenskapstypen skal indekseres.

Lovlige verdier:

J - Egenskapstypen skal indekseres

N - Egenskapstypen skal ikke indekseres

Avledet Angir om Egenskapstypen er avleda eller ikke.

Lovlige verdier:

J - Egenskapstypen er avleda

N - Egenskapstypen er ikke avleda

Ajourhold snu Angir om verdier tilknyttet denne Egenskapstypen er avhengig av vegens metreringsretning.

Lovlige verdier:

J - Verdier er avhengig av metreringsretning

N - Verdier er ikke avhengig av metreringsretning

TV kortnavn off Angir om kortnavn til tillatte verdier er offisielle eller ikke. Offisielle kortnavn blir vist sammen med navn i Dakat.

Lovlige verdier:

J - Tillatte verdier er offisielle

N - Tillatte verdier er ikke offisielle

Maks lengde Angir hvor lange kortnavnene til de tillatte verdiene kan være. Angitt i antall tegn. Formatet tillater inntil 8 tegn. Hvis f.eks. bare 2 tegn skal benyttes gis 2.

Fortegnsendring v/snu Angir om verdier knyttet til Egenskapstypen skal endre fortegn ved snuing av metreringsetning.

Lovlige verdier:

J - Fortegn skal endres

N - Fortegn skal ikke endres

Lengdeavhengig verdi Angir om verdi til denne Egenskapstypen er avhengig av vegobjektets utstrekning eller ikke.

Lovlige verdier:

J - Verdi blir ugyldig ved endring av vegobjektets utstrekning (eks. Areal, lengde, antall mm..)

N - Verdi er upåvirka av vegobjektets utstrekning

Oversikt Meny Verktøylinje Innhold i feltene Styringsparametere

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Tillatte verdier

Innhold i hovedskjermbildet ››

Oversikt Meny Verktøylinje I nnhold i feltene

Oversikt

Ved å dobbeltklikke på en forekomst av Tillatte verdier, eller klikke på en forekomst og trykke [image] kommer detaljskjermbildet for tillatte verdier opp:

Detaljskjermbilde av tillatte verdier

Meny

Øverst i skjermbildet er det en meny med følgende funksjoner:

Fil

Utskrift - Skriver ut innholdet i skjermbildet

Editer

Editer - Slår på redigering

Hjelp

Hjelp - Viser denne hjelpeteksten

Editer-knappen vil ikke være tilgjengelig medmindre du har rettigheter for redigering

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom Tillatte verdier

Verktøylinjen har følgende funksjoner:

Gå til første forekomst

Gå til forrige forekomst

Gå til neste forekomst

Gå til siste forekomst

Opprett ny forekomst

Slett forekomst

Lagre endringer

Kun knappene for å bla fram og tilbake vil være aktiv om du ikke har rettigheter for redigering.

Innhold i feltene

ID - Angir identitet til Tillatt verdi .

Navn - Angir navn til Tillatt verdi.

Egenskapstype - Gir relasjon til Egenskapstype som Tillatt verdi tilhører.

Vegobjekttype - Gir relasjon til Vegobjekttype som tillatte verdi tilhører

Sorteringsnr - Angir nummer til Tillatt verdi. Kan benyttes for sortering.

Kortnavn - Angir kortnavn for Tillatt verdi

Beskrivelse - Angir beskrivelse til Tillatt verdi.

Dato fra objektliste - Angir dato Tillatt verdi ble gyldig i Objektlista.

Dato fra NVDB - Angir dato Tillatt verdi ble gyldig for NVDB.

Std. Verdi - Angir om verdien er Standardverdi eller ikke.

Lovlige verdier:

J - Verdien er Standardverdi
N - Verdien er ikke Standardverdi

Oversikt Meny Verktøylinje I nnhold i feltene

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Tillatt sammenheng

Innhold i hovedskjermbildet ››

Oversikt Funksjoner for sammenheng Meny Verktøylinje Innhold i feltene

Oversikt

Nederst i hovedskjermbildet vises Tillatte sammenhenger for aktiv Vegobjekttype:

Figuren viser vindu for Tillatte sammenhenger med anvisning for aktuelle kommandoer

Venstre halvdel viser de vegobjekttyper aktiv vegobjekttype er koblet til. Høyre halvdel viser de vegobjekttyper som er koblet til aktiv vegobjekttype.

Aktiv vegobjekttype står her i de to midterste kolonner slik at den blir vegobjekttype B i venstre halvdel av skjermbildet og vegobjekttype A i høyre halvdel.

Funksjoner for sammenheng

Ved å dobbeltklikke på vegobjekttype A i venstre halvdel vil denne bli satt som aktiv vegobjekttype.

Ved å dobbeltklikke på vegobjekttype B i høyre halvdel vil denne bli satt som aktiv vegobjekttype.

Det finnes en rekke lovlige typer sammenhenger .

Ved å dobbeltklikke på en Sammenhengstype som f.eks. vil det komme et detaljbilde for denne sammenhengstypen:

Detaljskjermbilde av tillatte sammenhenger

Meny

Øverst i skjermbildet er det en meny med følgende funksjoner:

Fil

Utskrift - Skriver ut innholdet i skjermbildet

Editer

Editer - Slår på redigering

Hjelp

Hjelp - Viser denne hjelpeteksten

Editer-knappen vil ikke være tilgjengelig med mindre du har rettigheter for redigering

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom Sammenhengstyper

Verktøylinjen har følgende funksjoner:

Gå til første sammenhengstype

Gå til forrige sammenhengstype

Gå til neste sammenhengstype

Gå til siste sammenhengstype

Opprett ny sammenhengstype

Slett sammenhengstype

Lagre endringer

Kun knappene for å bla fram og tilbake vil være aktiv om du ikke har rettigheter for redigering.

Innhold i feltene

ID - Angir identitet til Tillatt sammenheng.

Type A - Gir vegobjekttype på venstre side av sammenheng.

Type B - Gir vegobjekttype på høyre side av sammenheng.

Sammenheng - Gir hvilken type sammenheng det er mellom de to vegobjekttypene

Rollenavn AB - Angir rollenavn A-B. Dette blir navn på "egenskapstypen" i NVDB.

Maks antall - Angir maksimalt antall for hvor mange objekt av type B som det er mulig å kople mot et objekt av type A.
999999 tilsvarer uendelig (n).

Min antall - Angir minimum antall for hvor mange objekt av type B det må være koplet mot et objekt av type A.
0 er standard. Dersom verdi er 1 eller større betyr det at et objekt av type A må minst ha ett objekt av type B kopla til seg.

Beskrivelse - Gir beskrivelse av sammenhengen.

Ledetekst - Angir tekst som skal benyttes som ledetekst i VegReg.

Dato fra - Angir dato Tillatt sammenheng ble gyldig i VDB.

Dato til - Angir dato Tillatt sammenheng ble ugyldig i VDB.

Dato fra NVDB - Angir dato Tillatt sammenheng ble gyldig i NVDB.

B slettes hvis A slettes - Angir om B skal slettes hvis A slettes

Lovlige verdier:

J - B slettes
N - B skal ikke slettes

Sted B innenfor A - Angir om stedfesting til B må være innenfor stedfesting til A.

Lovlige verdier:

0 - Nei
1 - Ja
2 - Ja, men sidepos/feltkode/høydepos kan avvike
9 - Ikke tatt stilling

Oversikt Funksjoner for sammenheng Meny Verktøylinje Innhold i feltene

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Verktøylinjen

Innhold i hovedskjermbildet ››

Øverst i skjermbildet finnes en verktøylinje hvor det gis tilgang til mye brukte funksjoner. Figuren under viser verktøylinjen i hovedskjermbildet:

Verktøylinjen til Datakatalogen

Følgende knapper er definert:

Søk

Viser skjermbildet Søk i hele datakatalogen . Dette gir deg muligheter til detaljert søk i datakatalogen.

Utskrift

Starter utskriftsfunksjonen . Funksjonaliteten til denne funksjonen vil være avhengig av hvilke valg du har gjort i listene i hovedskjermbildet.

Vis detaljer

Viser detaljbilde for det valgte objektet i listen eller trestrukturen

.

Logg

Viser logg over endringer i datakatalogen for valgt vegobjekttype eller for alle logglinjer

Endre visningsmodus

Bytter mellom Listevisning og Trestrukturvisning .

Åpne for redigering

Denne funksjonen åpner DAKAT for redigering av innholdet i Datakatalogen.

Det kreves spesielle rettigheter for å få lov til å redigere innholdet.

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Nivåer

Innhold i hovedskjermbildet ››

Menyvalg | Forklaring
Nivåer i Datakatalogen |
Tema | Velger hvilket hovedområde (tema) du ønsker å jobbe med
Vegobjekttype kategorier | Gir en underinndeling der vegobjekttyper som logisk hører sammen kan legges inn
Vegobjekttyper | Her listes vegobjekttypene som blir resultatet av de to første valgene
Egenskapstyper | Her listes alle egenskaper som tilhører valgt vegobjekttype
Tillatt verdier | Her listes tillatte verdier for den valgte egenskapen dersom dette er en egenskap med tillatte verdier
Asossiasjoner |
Tillatte sammenhenger | Her listes de vegobjekttyper som valgt vegobjekttype har assosiasjoner til, samt de vegobjekttyper som har assosiasjoner til valgt vegobjekttype
Er knyttet til | Her vises de vegobjekttyper som aktiv vegobjekttype kan eller må være knyttet til
Er tilknyttet | Her vises de vegobjekttyper som er knyttet til aktiv vegobjekttype

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Fil

Menyen Fil ser slik ut:

Innhold i menyen Fil

Import - Funksjoner for import av data til DAKAT

Eksport - Funksjoner for å eksportere data fra DAKAT

Utskrift - Utskrift og rapporter

Lukk - Avslutter programmet

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Import

Fil ››

Dette menyvalget inneholder en del importkommandoer

Det kreves spesielle rettigheter for å kunne kjøre disse kommandoene.

  • VDB, Oppdragsformat - Import av data fra gammel vegdatabank
  • ProKat database - Denne kommandoen importerer en ProKat database fra lokal PC og gjør den tilgjengelig for DAKAT
  • ProKat figurer - Denne kommandoen importerer figurer, tegninger, bilder mm fra lokal PC til server for DAKAT og gjør disse tilgjengelig for DAKAT.

Created with the Personal Edition of HelpNDoc: Free help authoring environment


VDB, oppdragsformat

Fil ›› Import ››

Her mangler forklaring.

Er denne aktuell enda?

Created with the Personal Edition of HelpNDoc: Easily create Help documents


ProKat database

Fil ›› Import ››

Denne kommandoen importerer en ProKat database fra lokal PC til DAKAT server og gjør den tilgjengelig for DAKAT.

For å kjøre denne kommandoen må du starte en spesialversjon av DAKAT som markert på oppstartbildet her:

Oppstartbilde med markering for riktig versjon av DAKAT for overføring av ProKat base.

Denne versjonen er laget for Datasekretariatet og krever en innlogging. Du må derfor skaffe deg brukernavn og passord for å få tilgang til denne versjonen.

For å starte importen velges menyvalget Fil/Import/Prokat database

Velg så den basen som skal importeres:

Velg fil og trykk Åpne/Open.

Basen importeres og en statusdialog viser framdriften

Trykk OK når importen er ferdig for å avslutte.

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


ProKat figurer

Fil ›› Import ››

Denne kommandoen importerer ProKat figurer fra lokal PC til DAKAT server og gjør disse tilgjengelige for DAKAT.

Husk å starte DAKAT på nytte etter overføringen.

For å kjøre denne kommandoen må starte en spesialversjon av DAKAT som markert på oppstartbildet her:

Oppstartbilde med markering for riktig versjon av DAKAT for overføring av ProKat base.

Denne versjonen er laget for Datasekretariatet og krever en innlogging. Du må derfor skaffe deg brukernavn og passord for å få tilgang til denne versjonen.

For å starte importen velges menyvalget Fil/Import/Prokat figurer

Velg så katalogen der filene ligger:

Alle filer på valgt katalog og alle underkataloger overføres.

Første sjekkes hvilke filer som ligger på valgt katalog og underkataloger

Framdriftsindikatoren viser hvor langt sjekken er kommet.

Deretter må du bekrefte at filer skal overføres:

En statusdialog viser framdriften i overføringa

Til slutt kommer denne som må bekreftes:

Overføringen er nå gjort og filene er tilgjengelig for DAKAT. Trykk OK for å avslutte.

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Eksport

Fil ››

Fil/Eksport gir mulighet for eksport av data fra Datakatalogen til en rekke formater:

Figuren viser menyvalg for Fil/Eksport

  • VDB, oppdragsformat Eksportere til VDB oppdragsformat
  • SQL-UML Eksportere tabelldefinisjoner til DDL, ArcGis eller UML
  • Web-side Eksportere innhold i objekttyper til Web-side (html)
  • Regneark Eksportere objektdefinisjoner til Microsoft Excel regneark

Created with the Personal Edition of HelpNDoc: Easily create Help documents


VDB, oppdragsformat

Fil ›› Eksport ››

Denne funksjonen eksporterer hele datakatalogen på formatet til Vegdatabanken.

Det kreves spesielle rettigheter for å kunne kjøre denne kommandoen.

Eksport til VDB

Du har her tre valg som bestemmer hvilke Vegobjekttyper som eksporteres.

Lovlige objekter

Denne funksjonen vil eksportere alle vegobjekttyper som for øyeblikket er aktiv i NVDB. Dette vil være objekter der fradato er satt, men ikke tildato.

Utgåtte objekter

Denne funksjonen vil eksportere objekter som er markert som utgått i NVDB. Dette vil være objekter der både fradato og tildato er satt, og tildato er tidligere enn dagens dato.

Objekter til behandling

Dette vil eksportere objekter som enda ikke er aktivert i NVDB. Dette vil være objekter der hverken fradato eller tildato er satt.

Denne knappen vil starte eksporten

Eksporten lagres på filen C:\Dakat\Datakatalog.txt

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


SQL-UML

Fil ›› Eksport ››

Oversikt Eksportformater Valg av vegobjekttype som skal eksporteres Bruk av Datakatalog id Utfør eksporten Eksempler på eksport

Oversikt

Denne funksjonen vil eksportere definisjonen for valgte Vegobjekttyper til en rekke forskjellige formater:

Eksportformater

Standard SQL

Eksporterer til standard SQL Data Definition Language ( DDL ). Denne eksporten vil eksportere definisjonene for valgt(e) vegobjekttype(r) inkludert alle vegobjekttyper som kan ha valgt vegobjekttype som morobjekt. Resultatet er en fil som kan importeres i et databasesystem for å opprette typedefinisjoner og tabeller med egenskaper tilsvarende innholdet i NVDB.

Oracle SQL

Eksporterer til Oracle Data Definition Language ( DDL ). Denne eksporten vil eksportere definisjonene for valgt(e) vegobjekttype(r) inkludert alle vegobjekttyper som kan ha valgt vegobjekttype som morobjekt. Resultatet er en fil som kan importeres i et Oracle databasesystem for å opprette typedefinisjoner og tabeller med egenskaper tilsvarende innholdet i NVDB.

MS Access SQL

Eksporterer til Microsoft Access Data Definition Language ( DDL ). Denne eksporten vil eksportere definisjonene for valgt(e) vegobjekttype(r) inkludert alle vegobjekttyper som kan ha valgt vegobjekttype som morobjekt. Resultatet er en fil som kan importeres i et Microsoft Access (Jet) databasesystem for å opprette typedefinisjoner og tabeller med egenskaper tilsvarende innholdet i NVDB.

Java klasser

Eksporterer alle egenskaper i valgte vegobjekttyper til Java klasser. Klassene kan tas inn og brukes til å håndere egenskapene i et Java programsystem.

Arc GIS tekstfil

Eksporterer fil som kan leses inn i ArcGis for oppretting av valgt(e) vegobjekttype(r) der.

UML

Eksporterer en XML-fil som inneholder UML-diagram for valgt(e) vegobjekttype(r) og alle vegobjekttyper som denne er mor til.

Valg av vegobjekter som skal eksporteres

Velg først Vegobjekttypekategori i listeboksen til venstre. Alle vegobjekttyper i kategorien listes i nederste listeboks. Velg så vegobjekttypen du vil eksportere. Vegobjekttypens døtre vises i listeboksen under vegobjekttypen.

Bruk knappen [image] for å flytte valgt vegobjekttype over til listeboksen helt til høyre. Det er listeboksen helt til høyre som viser de vegobjekttyper som skal eksporteres.

Dersom du vil fjerne en vegobjekttype fra listeboksen til høyre klikker du først på vegobjekttypen i lista og så velger du denne knappen:

Bruk av Datakatalog Id

Disse kommandoene gir en del mulighet for inkludering av tabellens id i Datakatalogen i navnet på tabelen.

Navn uten datakatalog id

Navnet på tabellen og egenskapene i eksporten vil være det samme som i datakatalogen. Eks. LEKEAPPARAT

Datakatalog id som prefiks

Navnet på tabellen i eksporten vil ha vegobjekttypens id i Datakatalogen som prefiks. Eks. 26_LEKEAPPARAT

Egenskapene vil få egenskapens id som prefiks

Datakatalog id som tillegg

Navnet på tabellen i eksporten vil ha vegobjekttypens id i Datakatalogen som tillegg. Eks. LEKEAPPARAT_26

Egenskapene vil få egenskapens id som tillegg

Valgfri tabellnavn prefiks

Navnet på tabellen og egenskapene i eksporten vil få en brukergitt tekststreng som prefiks. Eks. TP_LEKEAPPARAT (TP_ er gitt som prefiks)

Utfør eksporten

Klikk på Tillatte verdier i egen tabell for å få opprettet en tabell for hver type tillatt verdi. I motsatt fall kommer alle tillatte verdier i samme tabell.

Klikk på Eksporter utvalget for å starte eksporten. Du vil da få opp en dialog for å velge navn og plassering på eksportfilen:

Gi inn filnavn, velg plassering og trykk Lagre/Save. Eksporten kjøres og filen kommer så opp i notisblokk for de fleste typer eksport.

Eksempler på eksport

Utsnitt av eksportert DDL-fil for Standard SQL

Utsnitt av eksportert DDL-fil for Oracle

Java-klasse for en egenskap i objekttypen tunnelsjakt.

Utsnitt av eksportert fil for oppretting av Rekkverk i ArcGis

Utsnitt av eksportert XML-fil som kna brukes for å opprette UML-skjema for valgt vegobjekttype inkludert vegobjekttyper denne er mor til

Oversikt Eksportformater Valg av vegobjekttype som skal eksporteres Bruk av Datakatalog id Utfør eksporten Eksempler på eksport

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


Web-side

Fil ›› Eksport ››

Denne funksjonen brukes for å eksportere en eller flere Vegobjekttyper til en Web-side som en HTML-fil.

Dersom du har valgt en Vegobjekttypekategori kommer følgende dialog opp:

Eksport av vegobjekttypekategori

Her kan du velge å eksportere alle vegobjekttyper i valgt kategori, eller du kan velge å eksportere alle kategorier.

Kryss av i feltet Inkluder detaljer for å få med egenskaper og tillatte verdier for vegobjekttypene.

Om du har valgt en Vegobjekttype vil du få opp denne dialogen:

Eksport av vegobjekttype

Her kan du velge å eksportere valgt vegobjekttype eller du kan velge å eksportere alle vegobjekttyper i valgt kategori.

Etter å ha valgt hva du skal eksportere kommer det opp en dialog for å velge eksportfil:

Dialog for å velge filnavn og plassering

Velg sti og filnavn og trykk Lagre/Save. Valgte vegobjekttyper eksporteres og hentes opp i nettleseren f.eks. slik:

Eksempel på eksport av en vegobjekttype

Ved eksport av en Vegobjekttypekategori uten detaljer vil det se slik ut:

Eksempel på eksport av en Vegobjekttypekategori uten detaljer

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


Regneark

Fil ›› Eksport ››

Denne funksjonen eksporterer innhold fra Datakatalogen til Microsoft Excel regneark.

For å få eksportert må du minimum ha valgt en kategori. Du kan velge å eksportere Kategori eller Vegobjekttype.

Om du velger også Egenskapstype eller Tillatte verdier vil det som skrives ut være som om du velger Vegobjekttype.

Valg med fokus på Vegobjekttypekategori gir skjermbildet Eksporter kategori - til regneark

Valg med fokus på Vegobjekttype gir skjermbildet Eksporter vegobjekttype - til regneark

Skjermbilde Eksporter kategori - til regneark

Du kan velge å eksportere valgt kategori, eller du kan velge å eksportere alle kategorier.

Skjermbilde Eksporter vegobjekttype - til regneark

Velger du Vegobjekttype kan du velge å eksportere valgt vegobjekttype eller alle vegobjekttyper i valgt kategori

Før du går videre kan du velge hvilke objekttyper du vil ta med egenskaper fra i eksporten.

Med kategorier

Dersom denne er avkrysset vil du få med utvalgte felter fra den valgte kategorien i eksporten.

Med vegobjekttyper

Dersom denne er avkrysset vil du få med utvalgte felter fra vegobjekttypen(e) i eksporten.

Med egenskapstyper

Dersom denne er avkrysset vil du få med utvalgte felter fra alle egenskapstypene i eksporten.

Med tillatte verdier

Dersom denne er avkrysset vil du få med utvalgte felter fra alle tillatte verdier i eksporten.

Du kan også velge akkurat hvilke felter du vil ha med i eksporten som beskrevet her .

Trykk [image] for å gå videre og en dialog for filvalg kommer opp:

Velg filnavn og plassering og trykk Lagre/Save.

Fila lagres og åpnes i Excel:

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Valg av felter

Fil ›› Eksport ›› Regneark ››

Beskrivelse Meny Verktøylinje

Beskrivelse

I dette skjermbildet kan du bestemme hvilke felter som skal være med i eksporten. Her er vist oppsettbildet for Vegobjekttype. Tilsvarende oppsett finnes for Vegobjekttypekategori, Egenskapstype og Tillatte verdier.

Skjermbilde for feltvalg i eksporten

Kolonnene i tabellen har følgende funksjon

Synlig - Hvis avkrysset vil feltet bli med i eksporten

Navn - Feltnavn i databasen. Navn på datafeltene finner du her

Tittel - Populærnavn i databasen. Dette er et aliasnavn for feltnavnet. Du finner navnene her

Posisjon - Posisjon i skjermbildet for dette feltet. Vises i trinn på 10, slik at feltet med Posisjon = 50 vil være felt nr 6 i skjermbildet (første er 0).

Bredde - Gir bredden på feltet i eksporten

For å flytte et felt mellom to eksisterende felter gir du dette en posisjon med en verdi mellom de to. Om du vil sette inn et felt som nr tre kan du gi det posisjon 15 (eller hva som helst mellom 11 og 19). Neste gang du åpner skjermbildet vil dette feltet ha fått posisjon 20 og alle felter over vil være øket med 10.

Hvis du vil ha et felt til å stå sist i tabellen gir du det posisjon 999. Om du vil ha dette til å bruke resterende plass i tabellen gir du det feltbredde -1.

Meny

Menyen har følgende funksjoner

Fil

Utskrift - Denne funksjonen er ikke aktiv i dette skjermbildet

Lukk - Lagrer endringer og lukker skjermbildet

Editer

Ny - Legger inn en ny linje til slutt i tabellen

Lagre - Lagrer endringer

Slett - Sletter valgt linje i tabellen

Verktøylinje

Verktøylinjen har følgende funksjoner:

Ingen funksjon i dette skjermbildet

Ingen funksjon i dette skjermbildet

Ingen funksjon i dette skjermbildet

Ingen funksjon i dette skjermbildet

Lagre endringer

Beskrivelse Meny Verktøylinje

Created with the Personal Edition of HelpNDoc: Free EPub producer


Utskrift

Fil ››

Utskrift startes med:

Skriverknappen i Verktøylinjeen

Menyvalget Fil/Utskrift

Ctrl + P

Dersom en Vegobjekttypekategori har fokus når du velger utskrift kommer dette skjermbildet opp:

Dersom en Vegobjekttype har fokus når du velger utskrift kommer dette skjermbildet opp:

Skjermbilde for menyvalget Utskrift

Utskriftsfunksjonen er delt i to deler:

Utskrift - Lager utskrift til fil eller skriver for innhold i Datakatalogen

Denne knappen sender utskriften direkte til en skriver. Du vil da få opp en standard skriverdialog.

.Denne knappen sender utskriften til en fil

Rapporter - Lager en mer omfattende rapport for spesielle formål som f.eks. en produktspesifikasjon.

Rapportene sendes alltid til en HTML-fil ved å velge denne knappen

Ved utskrift til fil får du opp en standard filvalgsdialog:

Utskriftsdialog

Her kan du velge filnavn og plassering for filen. Programmet vil foreslå et filnavn. Trykk Lagre/Save for å lagre utskriften på valgt fil.

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Utskrift

Fil ›› Utskrift ››

Utskrift en Vegobjekttypekateori eller Vegobjekttype Utskrift flere Vegobjekttypkategorier eller Vegobjekttyper Enkel utskrift

Utskrift av en Vegobjekttypekategori eller Vegobjekttype

Utskrift valgt for en vegobjekttypekategori

Dersom du bare har valgt Vegobjekttypekategori vil du skrive ut for alle vegobjekttyper i denne kategorien.

Du kan enten velge å skrive ut data for den aktive Vegobjekttypekategorien (her Vegkonstruksjon), eller du kan skrive ut data for alle Vegobjekttypekategorier i valgt tema.

Har du også valgt Vegobjekttype vil du skrive ut bare denne vegobjekttypen som vist under:

Utskrift valgt for en enkel Vegobjekttype

Du kan enten velge å skrive ut data for den aktive Vegobjekttypen (her Skiltplate), eller du kan skrive ut data for alle vegobjekttyper i valgt Vegobjekttypekategori.

Utskrift for en vegobjekttype kan se slik ut:

Starten på utskrift for vegobjekttypen Skiltplate.

Utskrift av flere Vegobjekttypekategorier eller flere Vegobjekttyper

Dersom du bare har valgt Vegobjekttypekategori vil du få dialogen over. Du vil da få utskrift av alle vegobjekttyper i alle vegobjekttypekategorier i valg tema.

Har du i tillegg valgt vegobjekttype vil du få følgende dialog:

Velger du utskrift av alle vegobjekttyper som vist over vil du få utskrift for alle vegobjekttyper i valgt vegobjekttypekategori.

Underveis vil du få statusinformasjon ved at navnet på vegobjekttypene listes ut i dette skjermbildet:

Statusinformasjon under utskrift av flere vegobjekttyper

Utskriften for alle vegobjekttyper vil komme på samme fil.

Enkel utskrift

Dersom du fjerner krysset Inkluder detaljer vil du kun få en enkel listing av vegobjekttypene slik:

Utskrift en vegobjekttype Utskrift flere vegobjekttyper Enkel utskrift

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Rapporter

Fil ›› Utskrift ››

Nederste del av utskriftsdialogen inneholder 4 rapporter

Rapportdelen av utskriftsdialogen

Produktspesifikasjon Denne lager en komplett produktspesifikasjon for aktiv vegobjekttype og lagrer den på din lokale PC

Kvalitetskontroll Denne skriver ut et komplett skjema for kvalitetskontroll av aktiv vegobjekttype og lagrer den på din lokale PC

Kvalitetskrav Denne skriver ut en liste med kvalitetskrav for aktiv vegobjekttype og lagrer den på din lokale PC

Bruksområder Denne skriver ut en tabell med bruksområder og behov for aktiv vegobjekttype og lagrer den på din lokale PC

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Bruksområder

Fil ›› Utskrift ›› Rapporter ››

Denne rapporten gir en oversikt over hvilke formål aktiv vegobjekttype er brukt til, samt litt om hvilke egenskaper (behov) som er i bruk til dette formålet.

Der det er funnet hensiktsmessig er det også tatt med noen eksempler på bruken.

Dersom du finner bruksområder som ikke er dekket bør du melde dette inn til de ansvarlige i Vegdirektoratet, seksjon NVDB og Geodata

Eksempel på bruksområder

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


Kvalitetskrav

Fil ›› Utskrift ›› Rapporter ››

Denne rapporten gir deg de kravene som stilles til den aktive vegobjekttypen.

Kravene kan være av forskjellige typer, f.eks.

  • Krav til at objekter av gitt vegobjekttype skal være registrert.
  • Tidsfrist for at objektet skal være registrert
  • Krav til at egenskaper skal være gitt. Dette gjelder egenskaper som er definert med viktighet Påkrevd eller Betinget.
  • Nøyaktighet for stedfesting.
  • Forhold mellom objekter av flere vegobjekttyper, f.eks.:

- Rasteplass skal være mor til et toalettanlegg som ligger innenfor rasteplassens avgrensning

- Skiltplate må ha tilknytning til et skiltpunkt

Eksempel på kvalitetskrav

Kvalitetselementene er basert på ISO-standarder, og det vil derfor forekomme noen litt vanskelige uttrykk. En forklaring til noen av disse følger her:

Aktualitet - Brukes for å angi tidsrom fra et vegobjekt er plassert i terrenget og til det skal være oppdatert i NVDB

Konseptuelt skjema - En beskrivelse av sammenhengen mellom flere objekttyper

Konseptuell konsistens - Samsvar med regler i det konseptuelle skjema

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Kvalitetskontroll

Fil ›› Utskrift ›› Rapporter ››

Denne funksjonen vil skrive ut et komplett skjema for kvalitetskontroll av en vegobjekttype.

Kvalitetskontrollskjemaet vil inneholde følgende deler:

- Oversikt over egenskaper som det er krav for, dvs. som er betinget eller påkrevd

- Skjema over alle kontroller som skal utføres

- Alle krav som stilles til vegobjekttypen

- Detaljert beskrivelse av de kontroller som krever en mer utførlig beskrivelse

Utsnitt av skjema for kvalitetskontroll

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Produktspesifikasjon

Fil ›› Utskrift ›› Rapporter ››

Denne funksjonen vil lage en produktspesifikasjon som lagres som en HTML-fil der du bestemmer. Deretter vil filen åpnes og vises for deg i det programmet som er valgt som standard for visning av HTML-filer.

Produktspesifikasjonen vil innehold følgende deler:

  • Kjente bruksområder og behov
  • UML-skjema for vegobjekttypen som viser alle egenskaper og tillatte verdier.
  • UML-skjema med assosiasjoner til andre vegobjekttyper dersom sike assosiasjoner finnes.
  • Beskrivelse av vegobjekttypen
  • Beskrivelse av alle egenskaper for vegobjekttypen
  • Alle kvalitetskrav til vegobjekttypen
  • Innsamlingsregler som beskriver hvordan data skal innhentes og hvordan de skal registreres
  • Eksempler

En mer fullstendig beskrivelse av produktspesifikasjonen finner du her

Utsnitt av produktspesifikasjon

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Lukk

Fil ››

Dette menyvalget lukker programmet.

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Data

Menyvalget Data åpner for disse menyvalgene:

Figuren viser et skjermbilde av menyvalget Data.

Menyvalg | Forklaring
Tema | Velger hvilket hovedområde (tema) du ønsker å jobbe med
Vegobjekttype kategorier | Gir en underinndeling der vegobjekttyper som logisk hører sammen kan legges inn
Vegobjekttyper | Her listes vegobjekttypene som blir resultatet av de to første valgene
Egenskapstyper | Her listes alle egenskaper som tilhører valgt vegobjekttype
Tillatt verdier | Her listes tillatte verdier for den valgte egenskapen dersom dette er en egenskap med tillatte verdier
Tillatte sammenhenger | Her listes de vegobjekttyper som valgt vegobjekttype har assosiasjoner til, samt de vegobjekttyper som har assosiasjoner til valgt vegobjekttype
Er knyttet til | Viser hvilken vegobjekttype aktiv vegobjekttype eventuelt er knyttet til.
Er tilknyttet | Viser hvilke vegobjekttyper som eventuelt er knyttet til aktiv vegobjekttype

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Tema

Data ››

Viser liste med alle tema inkludert intern id, navn på tema, kortnavn for temaet og beskrivelse

Oversikt over alle definerte tema

Meny

Fil

Utskrift - Denne funksjonen er ikke aktiv i dette skjermbildet

Editer

Hjelp - Viser dette skjermbildet

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom Temaer, dvs. mellom linjene i tabellen. Du kan også bruke opp eller nedpilene på tastaturet for å bla mellom linjene i tabellen.

Verktøylinjen har følgende funksjoner:

Gå til første linje

Gå til forrige linje

Gå til neste linje

Gå til siste linje

Opprett ny linje

Slett linje

Lagre endringer

Gå til oppsettfunksjonen for dette skjermbildet

Kun knappene for å bla fram og tilbake, samt oppsettfunksjonen vil være aktiv om du ikke har rettigheter for redigering.

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Vegobjekttypekategori

Data ››

Dette skjermbildet viser liste med alle vegobjekttypekategorier innenfor valgt tema.

Dobbeltklikk på en linje i tabellen for å vise detaljskjermbildet for en vegobjekttypekategori.

Tabellen viser intern id, navn på vegobjekttypekategori, kortnavn for vegobjekttypekategori og beskrivelse

Oversikt over alle vegobjekttypekategorier i valgt tema

Meny

Fil

Utskrift - Denne funksjonen er ikke aktiv i dette skjermbildet

Editer

Hjelp - Viser dette skjermbildet

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom vegobjekttypekategorier, dvs. mellom linjene i tabellen. Du kan også bruke opp eller nedpilene på tastaturet for å bla mellom linjene i tabellen.

Verktøylinjen har følgende funksjoner:

Gå til første linje

Gå til forrige linje

Gå til neste linje

Gå til siste linje

Opprett ny linje

Slett linje

Lagre endringer

Gå til oppsettfunksjonen for dette skjermbildet

Kun knappene for å bla fram og tilbake, samt oppsettfunksjonen vil være aktiv om du ikke har rettigheter for redigering.

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Vegobjekttype

Data ››

Dette skjermbildet viser liste med alle vegobjekttyper innenfor valgt vegobjekttypekategori.

Dobbeltklikk på en linje i tabellen for å vise detaljskjermbildet for en vegobjekttype.

Tabellen viser intern id, navn på vegobjekttypen, kortnavn for vegobjekttypen og beskrivelse.

I tillegg kan Data fra og Dato til vises. Dersom Dato fra vises angir den datoen vegobjekttypen blir/ble aktiv i NVDB.

Dato til gis for vegobjekttyper som skal utgå, og datoen viser når den utgår/utgikk.

Oversikt over alle vegobjekttyper i valgt vegobjekttypekategori

Meny

Fil

Utskrift - Denne funksjonen er ikke aktiv i dette skjermbildet

Editer

Hjelp - Viser dette skjermbildet

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom vegobjekttyper, dvs. mellom linjene i tabellen. Du kan også bruke opp eller nedpilene på tastaturet for å bla mellom linjene i tabellen.

Verktøylinjen har følgende funksjoner:

Gå til første linje

Gå til forrige linje

Gå til neste linje

Gå til siste linje

Opprett ny linje

Slett linje

Lagre endringer

Gå til oppsettfunksjonen for dette skjermbildet

Kun knappene for å bla fram og tilbake, samt oppsettfunksjonenen vil være aktiv om du ikke har rettigheter for redigering.

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Egenskapstype

Data ››

Oversikt Meny Verktøylinje

Oversikt

Dette skjermbildet viser liste med alle egenskapstyper innenfor valgt vegobjekttype.

Dobbeltklikk på en linje i tabellen for å vise detaljskjermbildet for en egenskapstype.

Tabellen viser intern id, navn på egenskapstypen, kortnavn for egenskapstypen, sorteringsnr for egenskapen og beskrivelse

Oversikt over alle egenskapstyper i valgt vegobjekttype

Meny

Fil

Utskrift - Denne funksjonen er ikke aktiv i dette skjermbildet

Editer

Hjelp - Viser dette skjermbildet

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom egenskapstyper, dvs. mellom linjene i tabellen. Du kan også bruke opp eller nedpilene på tastaturet for å bla mellom linjene i tabellen.

Verktøylinjen har følgende funksjoner:

Gå til første linje

Gå til forrige linje

Gå til neste linje

Gå til siste linje

Opprett ny linje

Slett linje

Lagre endringer

Gå til oppsettfunksjonen for dette skjermbildet

Kun knappene for å bla fram og tilbake, samt oppsettfunksjonen vil være aktiv om du ikke har rettigheter for redigering.

Oversikt Meny Verktøylinje

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Tillatt verdi

Data ››

Dette skjermbildet viser liste med alle tillatte verdier for en valgt egenskapstype.

Dobbeltklikk på en linje i tabellen for å vise detaljskjermbildet for tillatte verdier.

Tabellen viser intern id, navn på tillatt verdi, kortnavn for tillatt verdi og beskrivelse

Oversikt over alle tillatte verdier for valgt egenskapstype

Meny

Fil

Utskrift - Denne funksjonen er ikke aktiv i dette skjermbildet

Editer

Hjelp - Viser dette skjermbildet

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom tillatte verdier, dvs. mellom linjene i tabellen. Du kan også bruke opp eller nedpilene på tastaturet for å bla mellom linjene i tabellen.

Verktøylinjen har følgende funksjoner:

Gå til første linje

Gå til forrige linje

Gå til neste linje

Gå til siste linje

Opprett ny linje

Slett linje

Lagre endringer

Gå til oppsettfunksjonen for dette skjermbildet

Kun knappene for å bla fram og tilbake, samt oppsettfunksjonen vil være aktiv om du ikke har rettigheter for redigering.

Created with the Personal Edition of HelpNDoc: Free EPub producer


Tillatte sammenhenger

Data ››

Dette skjermbildet viser liste med alle tillatte sammenhenger for en valgt vegobjekttype.

Dobbeltklikk på en linje i tabellen for å vise detaljskjermbildet for tillatte sammenhenger.

Tabellen viser intern id, navn på vegobjekttype A, sammenheng type, rollenavn, navn på vegobjekttype B og beskrivelse.

Oversikt over alle tillatte sammenhenger for valgt vegobjekttype

De forskjellige typene sammenheng er beskrevet her

Meny

Fil

Utskrift - Denne funksjonen er ikke aktiv i dette skjermbildet

Editer

Hjelp - Viser dette skjermbildet

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom tillatte sammenhenger, dvs. mellom linjene i tabellen. Du kan også bruke opp eller nedpilene på tastaturet for å bla mellom linjene i tabellen.

Verktøylinjen har følgende funksjoner:

Gå til første linje

Gå til forrige linje

Gå til neste linje

Gå til siste linje

Opprett ny linje

Slett linje

Lagre endringer

Gå til oppsettfunksjonen for dette skjermbildet

Kun knappene for å bla fram og tilbake, samt oppsettfunksjonen vil være aktiv om du ikke har rettigheter for redigering.

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Er knyttet til

Data ››

Dette skjermbildet viser vegobjekttyper som aktiv vegobjekttype kan være knyttet til.

Skjermbildet er bortsett fra overskriften akkurat det samme som skjermbildet for Er tilknyttet

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Er tilknyttet

Data ››

Dette skjermbildet viser vegobjekttyper som kan være knyttet til aktiv vegobjekttype.

Skjermbilde for å bla mellom vegobjekttyper som er knyttet til aktiv vegobjekttype - her Tunnelløp

Innhold i feltene

Type - Den aktiv vegobjekttypen som har objekter fra andre vegobjekttyper tilknyttet

Sammenheng - Beskriver hvilken type relasjon det er mellom de to vegobjekttypene

Nr | Navn | Kategori | Kortnavn | Beskrivelse
1 | Består av_er del av | Komposisjon | Sterk | Sammenhengtypen forteller at det er sterk binding mellom objekttypen A og B. Objekt A består av objekt B, objekt B er del av A. Objekt B slettes hvis A slettes. Eksempel "Skjerm" består av "Skjermvegg". "Skjermvegg" er del av "Skjerm"
2 | Har_tilhører | Aggregering | Svak | Sammenhengtypen forteller at det er en svak binding mellom objekttype A og B. Objekt A har objekt B, objekt B tilhører objekt A. Objekt B slettes ikke om A slettes. Eksempel: "Person" har "Bil" - "Bil" tilhører "Person"
3 | Har tilkoplet_er tilkoplet til | Assosiasjon | Løs | Sammenhengtypen forteller at det er en løs sammenheng mellom objekttype A og B. Objekt A og B er likeverdige i forhold til hverandre. Eksempel: "Bord" har tilkoplet "Stol". "Stol" er koplet til "Bord".
4 | Har subtype_er subtype av |  | arv | Utgått, egen relasjon i Vegobjekttype
5 | Er identisk med_har kopi |  | Kloning | Objekt B er en kopi av objekt A.
6 | Starter i_er start for |  | Start-Slutt | Objekt A starter i objekt B
7 | Slutter i_er slutt for |  | Slutt-Start | Objekt A slutter i objekt B
8 | Til venstre for_til høyre for |  | Venstre-Høyre | Objekt A ligger til venstre for B
9 | Til høyre for |  | Høyre-Venstre | Objekt A ligger til høyre for B
10 | Over_under | all | Over-Under | Objekt A ligger til over B
11 | Under |  | Under-Over | Objekt A ligger til under B. Eksempel: "
12 | Har_tilhører |  | Mor-datter | Objekt B tilhører objekt A. Eksempel: "Bord" har "Ileggsplate" - "Ileggsplate" tilhører "Bord"
13 | Lokaliserer_er lokalisert i |  | Lokalisering | Objekt B er lokalisert i objekt A. Eksempel "Stue" lokaliserer "Bord". "Bord er lokalisert i "Stue"

Lovlige verdier for sammenheng type

Type B - Den vegobjekttypen som er tilknyttet den aktive vegobjekttypen

Rollenavn AB -

Maks antall - Maks antall objekter av type B som kan være knyttet til type A

Min antall - Min antall objekter av type B som må være knyttet til type A

Dato fra - Dato relasjonen er gjeldende fra

Dato til - Dato relasjonen er gjeldende til

Dato fra NVDB - Angir dato Vegobjekttypen ble gyldig for bruk i NVDB. I praksis ble den gyldig i første versjon etter denne dato.

B slettes hvis A slettes - Hvis denne er avkrysset skal tilknyttede objekter av type B slettes hvis et objekt av type A slettes

Sted B innenfor A - Hvis denne er avkrysset må vegobjekttype B være innenfor Vegobjekt av type A

Beskrivelse - Beskrivelse av relasjonen

Ledetekst - Ledetekst som kan brukes i skjermbilder i stedet for relasjonens teksst i feltet sammenheng

Meny

Fil
Utskrift - Denne funksjonen er ikke aktiv i dette skjermbildet
Editer
Hjelp - Viser denne hjelpeteksten

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom vegobjekttyper som kan være tilknyttet aktiv vegobjekttype.

Verktøylinjen har følgende funksjoner:

Gå til første tilknyttede vegobjekttype

Gå til forrige tilknyttede vegobjekttype

Gå til neste tilknyttede vegobjekttype

Gå til siste tilknyttede vegobjekttype

Opprett ny tilknyttet vegobjekttype

Slett tilknyttede vegobjekttype

Lagre endringer

Kun knappene for å bla fram og tilbake, samt oppsettfunksjonen vil være aktiv om du ikke har rettigheter for redigering.

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Logg

Data ››

Denne kommandoen viser en liste over loggforekomster for Datakatalogen.

Funksjonen kan startes fra Data/Logg, eller fra knappen [image] på verktøylinja i hovedskjermbildet.

Hvis den startes fra knappen i verktøylinja og en vegobjekttype har fokus i listen Vegobjekttype startes skjermbildet Logg for type "xxx". Ellers startes skjermbildet Logg for datakatalog.

Klikk på en linje i tabellen for å vise hele beskrivelsen for en loggforekomst i feltene under tabellen.

Knapper for valg av type logglinjer

Disse knappene vises ikke i skjermbildet Logg for type "xxx" dersom loggen er startet fra verktøylinjen når en vegobjekttype har fokus i listen Vegobjekttype.

- Viser alle loggforekomster i databasen.

- Viser de logglinjer som ikke har knytting mot en vegobjekttype

Meny

Øverst i skjermbildet er det en meny med følgende funksjoner:

Fil

Utskrift - Skriver ut innholdet i skjermbildet

Editer

Editer

Hjelp

Hjelp - Viser denne hjelpeteksten

Editer-knappen vil ikke være tilgjengelig medmindre du har rettigheter for redigering

Verktøylinje

Under menyen har vi en verktøylinje der man kan bla mellom linjene i loggtabellen

Verktøylinjen har følgende funksjoner:

Gå til første forekomst

Gå til forrige forekomst

Gå til neste forekomst

Gå til siste forekomst

Opprett ny forekomst

Slett forekomst

Har ingen funksjon i dette skjermbildet

Setter et filter for utvalg av logglinjer. Se beskrivelse her .

Endre filter for utvalg av logglinjer. Se beskrivelse her .

Nullstiller filter

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Bruk av filter

Data ›› Logg ››

Denne funksjonen brukes for å gjøre utvalg av innholdet i loggen for derved å finne den delen av loggen man er interessert i.

Du kan lage et utvalg på kombinasjoner av følgende egenskaper:

Id - Id for logg

Type - Type logg

Dato - Dato loggen er skrevet

Ansvarlig - Ansvarlig for loggføringen

Beskrivelse - Beskrivelsen av endring/retting

Ved trykk på [image] eller [image] endres dialoogen til en filterdialog:

Eksempel på filter for logg.

Du kan nå sette opp det filteret du ønsker. Når filteret er satt viser du resulatet ved å trykke på

Sette filter

Du kan sette filter på et felt eller på flere felter

Operatorer

Følgende operatorer kan brukes i filterdialogen :

= Søk på likhet med søkeverdi. Virker på både tall og tekst. Dersom operator ikke gis tolkes det som =

> Større enn. Resultatet viser alle poster med innhold større enn søkeverdien. Kan bare brukes på tallfelter og dato

< Mindre enn. Resultatet viser alle poster med innhold mindre enn søkeverdien. Kan bare brukes på tallfelter og dato

<= Mindre eller lik. Resultatet viser alle poster med innhold mindre eller lik søkeverdien. Kan bare brukes på tallfelter og dato

>= Større eller lik. Resultatet viser alle poster med innhold større eller lik søkeverdien. Kan bare brukes på tallfelter og dato

Søk på tekster i feltet Beskrivelse

Du kan gi en eller flere tekster i søkestrengen. Resultatet vil bli de logglinjer som inneholder ALLE tekstene. Tekstene du gir kan være hele eller deler av ord i beskrivelsen.

Du trenger ikke å gi noen operator ved søking på tekster.

Eks: Dersom du gir søkestrengen materialtype betongstein vil du få de logglinjer som inneholder begge disse ordene.

Dersom du gir søkestrengen materialtype betong vil du få de logglinjer som inneholder materialtype. og enten betong eller betongstein

Filter på ID

Du kan bruke alle operatorer for søk på ID.

Eks: = 200

> 300

>= 250

<= 500

< 461

Filter på type logg

Du kan finne logger av en bestemt loggtype ved å velge denne loggtypen i flervalgsboksen Type. Du kan velge blandt disse typene:

Datamodell - Endring i selve datamodellen i Datakatalogen

Innhold i datakatalog - Endring av innholdet i Datakatalogen

Kommentar - Svar eller kommentar til innhold

Spørsmål - Svar på spørsmål som er kommet inn

DAKAT-programmet - Endringer i selve DAKAT-programmet

Objektlista - Endringer på va som skal være med i objektlista.

For å vise loggen uten filter på Type må du velge [image] .

Filter på dato

Filter på dato gis inn som en sammenhengende tekst på formen ååååmmdd

Alle operatorer kan brukes på dato

Eks: 20091102

>20110823

<20010930

>=20110202

<>20030506

Filter på ansvarlig

Gi inn navn eller initialer for den ansvarlige du vil vise logg fra. Du kan gi hele eller deler av navnet.

Eks: Alle disse vil gi som resultat de logglinjer med ansvarlig vb:

vb

VB

v

b

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Oppsettfunksjonen for skjermbildene

Data ››

Beskrivelse Meny Verktøylinje

Beskrivelse

Flere av skjermbildene i Data-menyen har en oppsettfunksjon der du kan velge hvilke felter som skal vises, hvilken posisjon de skal ha i skjermbildet og feltbredde.

I figuren under vises oppsettbildet for Vegobjekttyper, men funksjonaliteten er den samme for alle oppsettbildene for funksjonene i Data-menyen.

Oppsettfunksjonen for vegobjekttype

Kolonnene i tabellen har følgende funksjon

Synlig - Hvis avkrysset vil feltet vises i skjermbildet

Navn - Feltnavn i databasen. Navn på datafeltene finner du her

Tittel - Populærnavn i databasen. Dette er et aliasnavn for feltnavnet. Du finner navnene her

Posisjon - Posisjon i skjermbildet for dette feltet. Vises i trinn på 10, slik at feltet med Posisjon = 50 vil være felt nr 6 i skjermbildet (første er 0).

For å flytte et felt mellom to eksisterende felter gir du dette en posisjon med en verdi mellom de to. Om du vil sette inn et felt som nr tre kan du gi det posisjon 15 (eller hva som helst mellom 11 og 19). Neste gang du åpner skjermbildet vil dette feltet ha fått posisjon 20 og alle felter over vil være øket med 10.

Hvis du vil ha et felt til å stå sist i tabellen gir du det posisjon 999. Om du vil ha dette til å bruke resterende plass i tabellen gir du det feltbredde -1.

Meny

Menyen har følgende funksjoner

Fil

Utskrift - Denne funksjonen er ikke aktiv i dette skjermbildet

Lukk - Lagrer endringer og lukker skjermbildet

Editer

Ny - Legger inn en ny linje til slutt i tabellen

Lagre - Lagrer endringer

Slett - Sletter valgt linje i tabellen

Verktøylinje

Verktøylinjen har følgende funksjoner:

Gå til første linje i tabellen

Gå til forrige linje i tabellen

Gå til neste linje i tabellen

Gå til siste linje i tabellen

Lagre endringer

Beskrivelse Meny Verktøylinje

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


Oppsett

Menyvalget Oppsett gir disse menyvalgene:

Figuren viser et skjermbilde av menyvalget Oppsett

Funksjoner i Oppsett-menyen:

Kobling kategori-vegobjekttype Bestemmer koblinger mellom Typekategori og Vegobjekttype.

Egenskapstype Dette menyvalget gir kodelister for Enheter, datatyper og kategorier

Debug Slår på debugutskrift på server

Klientlogg

Created with the Personal Edition of HelpNDoc: Free EPub producer


Kobling kategori-vegobjekttype

Oppsett ››

Dette menyvalget åpner skjermbildet som vist i figuren under. Her kan du bestemme hvilke vegobjekttyper som skal være med i de forskjellige Vegobjekttypekategorier.

Det kreves spesielle rettigheter for å kunne kjøre denne kommandoen.

Figuren viser et skjermbilde for kobling av Vegobjekttyper til Vegobjekttypekategorier

Velg først hvilken Vegobjekttypekategori du vil jobbe med i listen til venstre

Neste liste vil vise hvilke Vegobjekttyper som for øyeblikket er inkludert i valgt kategori.

Legg til vegobjekttype i kategorien

Klikk på den vegobjekttypen du vil inkludere i listen til høyre og trykk knappen [image] .

Vegobjekttypen legges til kategorien og vises i listen i midten.

Fjern vegobjekttype fra kategorien

Klikk på vegobjekttypen du vil fjerne fra listen i den midterste listen og trykk knappen

Nr i liste

Her kan du sette inn et nummer for å styre rekkefølgen vegobjekttypene legge sinn i listen over vegobjekttyper som tilhører kategorien.

Primærkategori

En vegobjekttype kan ligge i flere kategorier. Med denne knappen bestemmer du hvilken kategori som skal være den primære.

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Egenskapstype

Oppsett ››

Dette menyvalget gir deg muligheter til å se på og hvis du har rettigheter endre oppsett for egenskaper:

  • Enheter - Enheter som gis inn i for de forskjellige typer egenskaper
  • Datatyper - Hvilke datatyper egenskapene kan tilordnes
  • Kategorier - Hvilke kategorier for egenskaper som skal være tilgjengelig

Det kreves spesielle rettigheter for å kunne kjøre disse kommandoene.

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Enheter

Oppsett ›› Egenskapstype ››

Dette skjermbildet viser alle lovlige typer enheter som kan brukes i DAKAT:

Lovlige enheter i DAKAT

Ved behov kan det defineres inn nye enheter her. Dette krever imidlertid skrivetilgang i DAKAT.

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


Datatyper

Oppsett ›› Egenskapstype ››

Dette skjermbildet viser alle lovlige datatyper i DAKAT.

Datatyper i DAKAT

Her vises også kortnavn og en forklaring til hver datatype. Nye datatyper kan legges inn ved behov, men dette krever skrivetilgang til databasen.

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Kategorier

Oppsett ›› Egenskapstype ››

Dette skjermbildet viser en oversikt over alle kategorier av egenskapstyper:

Kategorier av egenskapstyper

Egenskapene er tilordnet en kategori som sier litt om hvor egenskapen kommer fra og/eller hva egenskapen beskriver og skal brukes til.

I detaljskjermbildet for egenskaper finner du kategorien som vist her:

Egenskapskategori i detaljskjermbildet for egenskapstyper

Det er mulig å definere nye kategorier i DAKAT for den som har skrivetilgang.

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


Debug

Oppsett ››

Dette menyvalget setter programmet i Debug-modus.

I Debug-modus vil programmet skrive ut informasjon om eksekveringen på en loggfil på serveren.

Denne informasjonen kan brukes til å finne ut hvor i programmet en feil oppstår, og vil typisk være nyttig for den som utvikler og drifter programmet.

Det kreves spesielle rettigheter for å kunne kjøre denne kommandoen.

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Klientlogg

Oppsett ››

Denne kommandoen viser en liste med aktive brukere som kjører programmet.

Det kreves spesielle rettigheter for å kunne kjøre denne kommandoen.

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Verktøy

Dette menyvalget inneholder en del verktøy og har følgende funksjoner:

  • Kontroll av SOSI-NVDB filer Funksjon for å kjøre kontroll på SOSI-NVDB filer før de importeres

  • Kvalitetskontroll Kvalitetskontroll av innholdet i Datakatalogen

  • Sammenlign datakataloger Funksjon for å sammenligne to versjoner av datakatalogen

  • Søk Søke etter objekttyper, egenskaper eller tillatte verdier

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Kontroll av SOSI-NVDB filer

Verktøy ››

Oversikt Generelle kontroller Kontroll, vegobjekttype Kontroll, tillatt sammenheng Kontroll, vegobjekttypekategoriindeling Kontroll, egenskapstype Kontroll, tillatt verdi

Kontroll av SOSI-NVDB filer

Denne funksjonen brukes til å kontrollere innholdet på SOSI-NVDB filer før data importeres til NVDB.

Kontrollen vil foregå mot den versjonen av Datakatalogen eller Objektlista som den versjonen du kjører på er satt opp til å kjøre mot.

Dette skjermbildet viser siden for SOSI kontroll.

Legg til filer

Trykk denne knappen for velge de filer du vil kontrollere. For å velge flere filer kan du:

Holde nede Shift-tasten for å velge filer fra og til i fil-listen

Holde nede Ctrl-tasten for å legge til enkeltfiler

Rapport type

Dersom du ønsker en rapport over feil og mangler i en Excel-fil velger du Rapport i regneark.

Rapporten vil da komme på en fil som heter SosiRapport.csv og vil komme opp i MicroSoft Excel når rapporten er ferdig. Ønsker du å bruke et annet filnavn kan du enten trykke på knappen Fil og velge en fil, eller du kan skrive inn filnavn i feltet bak knappen Fil. Husk at filen i begge tilfeller må ha filtype .CSV.

Når du har fått opp filen i Excel kan du jobbe med den som du ønsker og så lagre den i det formatet du vil.

Om du vil ha skrevet meldingene direkte inn i SOSI-filen velger du knappen Rapport i SOSI-filer.

De originale filene vil ikke bli overskrevet, men du må ha skrivetilgang til katalogen der de ligger slik at rapportfilene som har samme navn som originalfilene bare med understrek (_) foran og _rapport bak kan lagres der.

Kontrollfilen for f.eks. SOSI-filen NVDB_Belysningspunkt_87.sos vil få navnet _nvdb_belysningspunkt_87-rapport.sos

Utvalg

Du kan velge å kontrollere SOSI-filene mot bare Objektlista, eller mot Hele Datakatalogen ved å velge i boksen vist over.

Kontroll av gitte vegobjekttyper.

Du kan kontrollere at gitte vegobjekttyper finnes i de filene som kontrolleres. Dette gjør du ved å velge fanen Ønskede vegobjekttype forekomster slik:

Her kan du gi inn ID for de vegobjekttypene du vil kontrollere. Du gir id for en vegobjekttype på hver linje.

Du kan også lime inn en liste med vegobjekttyper fra f.eks. et regneark ved hjelp av utklippstavlen. Merk og kopier objekttypene i programmet du vil hente dem fra og trykk Lim inn typer fra utklippstavle her.

Trykk Nullstill liste for å tømme listen over vegobjekttyper.

Starte kontrollen

Trykk på denne knappen for å starte kontrollen.

Det kommer opp et vindu som viser hvilken fil som til enhver tid kontrolleres:

Etter at kontrollen er ferdig kommer denne dialogen opp:

Her kan du velge å åpne filen direkte (Open eller Åpne), Lagre filen (Save eller Lagre) eller å lagre filen med et navn som du gir selv (Save as eller Lagre som).

Rapportfilen kan starte f.eks. slik som dette:

Om du har valgt sjekkking av om objekttyper finnes på filene vil dette kommeut slik:

Om du har valgt å gi feilmeldingene direkte i SOSI-filen vil disse skrives inn som en kommentar i filen og alle filene kommer opp. De kan se slik ut:

Oversikt Generelle kontroller Kontroll, vegobjekttype Kontroll, tillatt sammenheng Kontroll, vegobjekttypekategoriindeling Kontroll, egenskapstype Kontroll, tillatt verdi

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Kvalitetskontroll

Verktøy ››

Oversikt Generelle kontroller Kontroll, vegobjekttype Kontroll, tillatt sammenheng Kontroll, vegobjekttypekategoriindeling Kontroll, egenskapstype Kontroll, tillatt verdi

Oversikt

Denne funksjonen kan kjøre en rekke kontroller på Datakatalogen. Disse kontrollene kjøres før nye versjoner gis ut.

Det kreves spesielle rettigheter for å kunne kjøre denne kommandoen.

Resultat av kontroll

Nedenfor er en spesifikasjon av kontrollfunksjoner som finnes i Datakatalogen.

Forkortelser brukt nedenfor:

VT = Vegobjekttype

ET = Egenskapstype

TV = Tillatte verdier

TS = Tillatt sammenheng

VJ =

LG =

Generelle kontroller

G1 – Ulovlige tegn

Kontrollerer at det ikke finnes ulovlige tegn i noen tekster f.eks ”;” (semikolon).

G2 - Datokontroll

Dato skrives inn som et tall i Datakatalogen. For å sikre at det ikke gis inn urimelige verdier er det laget noen kontroller tilknyttet alle datoer i Datakatalogen. Datokontroll utføres for følgende datafelt:

    • VT.dato_fra
    • VT.dato_til
    • VT.NVDB_dato
    • ET.dato_fra
    • ET.dato_til
    • ET.NVDB_dato
    • TV.dato_fra
    • TV.dato_til
    • TV.NVDB_dato
    • TS.dato_fra
    • TS.dato_til
    • TS.NVDB_dato
    • VJ.Dato
    • LG.dato

Datokontroll består av følgende trinn:

    • G2-1 Kontrollerer at feltlengde = 8
    • G2-2 Kontrollerer at årstall < i år+1 og > 1996 (årstall er siffer 1-4)
    • G2-3 Måned >0 og < 13 (siffer 5 og 6)
    • G2-4 Dag >0 og mindre enn 32 (siffer 7 og 8) hvis måned = 1, 3, 5, 7, 8, 10 el.12
    • G2-5 Dag >0 og mindre enn 31 (siffer 7 og 8) hvis måned = 4, 6, 9, 11
    • G2-6 Dag >0 og mindre enn 30 (siffer 7 og 8) hvis måned = 2

Kontroll, vegobjekttype

VT-1 Vegobjekttype til-/fradato

VT.VDB-tildato skal ikke ha verdi >0 hvis ikke VT.VDB-fradato har verdi >0

Kontroll, tillatt sammenheng

TS-1 – NVDB-dato

Hvis TS.NVDB-dato>0 må TS.NVDB-dato være større enn 0 for begge vegobjekttypene som inngår i sammenhengen

TS-2 – VDB-dato

Hvis TS.VDB-fradato>0 og TS.VDB-tildato = 0, må TS.VDB-fradato være større enn 0 og TS.VDB_tildato være lik 0 for begge tilhørende objekttyper. TS.VDB-tildato skal ikke ha verdi >0 hvis ikke TS.VDB-fradato har verdi >0

TS-3 - Unik

Vegobjekttype A, vegobjekttypeB og tillatt sammenhengstype skal sammen være unike

Kontroll, vegobjekttypekategoriindeling

VTK-1 Kategori ”Alle” inneholder alle vegobjekttyper

Vegobjekttypekategori ”Alle” skal ha 1 eks av alle vegobjekttyper

VTK-2 Primærkategori

Alle vegobjekttyper har 1 primærkategori, (verken mer eller mindre)

Kontroll, egenskapstype

ET-1, Generelt, tallattributter

ET.Enhet, ET.Antall_desimaler, ET.Maksverdi og ET.Minverdi kun gitt for egenskapstyper som er av type ”Tall” (2) og ”Fastverdi, tall” (31)

ET-2, Feltlengde geometridatatyper

ET.Feltlengde ikke gitt for geometridatatyper ++ (17,18,19,20,21,22,23,24,26, 27?, 28?, 29?, 33-36?)

ET-3, NVDB-dato

Hvis ET.NVDB-dato>0 må VT.NVDB-dato være større enn 0 for tilhørende objekttype

ET-4, VDB-dato

Hvis ET.VDB-fradato>0 og ET.tildato=0, må VT.VDB-fradato være større enn 0 og VT.VDB_tildato være lik 0 for tilhørende objekttype. ET.VDB-tildato skal ikke ha verdi >0 hvis ikke ET.VDB-fradato har verdi >0

ET-5, Tilhørighet til VT

Følgende kontrolleres:

  • En Egenskapstype skal ha referanse til objekttype, bortsett fra ett unntak: Egenskapstypen er subtype av annen egenskapstype, dvs ET.Id_super_egtype er ulik 0
  • En egenskapstype som har verdi ulik 0 i feltet ET.ID_super_egtype, må referere til en egenskapstype som er av datatype ”Struct” (26).

ET-6, Dekningsgrad (uaktuell)

Kontroll av datafelt ”Dekningsgrad”: Rekkefølge og valg av bokstaver.

  • Maks 6 tegn
  • Kun ERFKPA er lovlige bokstaver å benytte. + G? (NB ! Datafelt utvides?)
  • Ikke lov å ha to like bokstaver
  • Rekkefølge skal alltid være ERFKPA
  • Store bokstaver skal benyttes

ET-8, Kontroll av ET av datatype tekst (1)

Følgende kontrolleres:

  • ET.Feltlengde har verdi
  • ET.Maske har ikke flere tegn enn ET.Feltlengde
  • ET.Defaultverdi er i henhold til ET.feltlengde

ET-9, Kontroll av ET av datatype tall (2)

Følgende kontrolleres:

  • ET.Feltlengde har verdi
  • ET.Feltlengde > ET.antall desimaler+1
  • ET.Maksverdi har verdi i henhold til ET.feltlengde og ET.Antall_desimaler
  • ET.Minverdi har verdi i henhold til ET.feltlengde og ET.Antall_desimaler
  • ET.Defaultverdi har verdi i henhold til ET.feltlengde og ET.Antall_desimaler
  • Det er gitt verdi for ET.maks når det er gitt for ET.min og omvendt
  • ET.Maks > ET.Min
  • ET.Maske for tallverdier er gitt som xx.xx ut fra gitt feltlengde og antall desimaler

ET-10 Kontroll av ET av datatype dato (8)

Følgende kontrolleres:

  • ET.Feltlengde = 8 gir ET:Maske = ååååmmdd
  • ET.Feltlengde = 6 gir ET:Maske = ååååmm
  • ET.Feltlengde = 4 gir ET:Maske = åååå

ET-10 Kontroll av ET av datatype kortdato (9)

Følgende kontrolleres:

  • ET.Feltlengde = 4 gir ET:Maske = mmdd

ET-11 Kontroll av ET av datatype klokkeslett (10)

Følgende kontrolleres:

ET.Feltlengde = 4 gir ET:Maske = hhmm

ET.Feltlengde = 6 gir ET:Maske = hhmmss

ET.Feltlengde = 8 gir ET:Maske = hhmmsshh

ET-11 Kontroll av ET av datatype, Struct (26)

Følgende kontrolleres:

  • Det må finnes minst 1 egenskapstype som refererer til en egenskapstype av type ”Struct”.
  • Hvis en egenskapstype av type struct har NVDB-dato, må minst en av de tilknytta egenskapstypene ha NVDB-dato
  • ET.Antall kan ikke gis > 1 ?

ET-12 Kontroll av ET av datatype Fastverdi-tekst (30)

Følgende kontrolleres:

  • Det må være tilknyttet minst 1 stk tillatt verdi.
  • Dersom egenskapstype har NVDB-dato må minst en av de tilknytta tillatte verdiene også ha NVDB-dato. Samme gjelder VDB-fradato
  • Tekstlengde av TV.Navn må ikke > ET.feltlengde

ET-12 Kontroll av ET av datatype Fastverdi-tekst (31))

Følgende kontrolleres:

  • Det må være tilknyttet minst 1 stk tillatt verdi.
  • Dersom egenskapstype har NVDB-dato må minst en av de tilknytta tillatte verdiene også ha NVDB-dato. Samme gjelder VDB-fradato
  • Tekstlengde av TV.Navn må være i henhold til ET.Feltlengde og ET.Antall_desimaler

Kontroll, tillatt verdi

TV-1 Tillatt verdi, tilhørighet

Tillatt verdi hører til egenskapstype som er av datatype 30 eller 31 (fastverdiattributter)

TV-2 Tillatt verdi, NVDB-datot

Hvis TV.NVDB-dato>0 må ET.NVDB-dato være > 0 for tilhørende Egenskapstype.

TV-3 Tillatt verdi ,VDB-datot

Hvis TV.VDB-fradato>0, og TV.VBD-tildato = 0 må ET.VDB-fradato være > 0 og ET.VDB-tildato være lik 0 for tilhørende Egenskapstype. TV.VDB-tildato skal ikke ha verdi >0 hvis ikke TV.VDB-fradato har verdi >0

Oversikt Generelle kontroller Kontroll, vegobjekttype Kontroll, tillatt sammenheng Kontroll, vegobjekttypekategoriindeling Kontroll, egenskapstype Kontroll, tillatt verdi

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Sammenlign datakataloger

Verktøy ››

Denne kommandoen vil sammenligne aktiv Datakatalog med en tidligere versjon.

Det kreves spesielle rettigheter for å kunne kjøre denne kommandoen.

Valg av rapportfil

Valg av tidligere versjon

Trykk på knappen [image] og velg Access-basen for en tidligere versjon. Velg Åpne/Open.

Valg av eldre Datakatalog for sammenligning

DAKAT går gjennom tabell for tabell og beskriver hva som er forskjell. Det vises i første rekke forskjell på innhold.

Forskjell i modell kan være aktuelt å vise. Vi ser for oss at følgende typer endringer skal kunne detekteres:

Innhold (for alle tabeller):

Ny forekomst

Endring av forekomst

Sletting av forekomst

For hver av disse endringstypene lages det en standard presentasjonsmåte. En slik rapport vil avsløre eventuelle utilsikta endringer. Den vil også gi oss mulighet til å sjekke at loggen er komplett i forhold til endringer som faktisk er gjort.

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Søk

Verktøy ››

Oversikt Type søk Søk Vis detaljer

Oversikt

Dette skjermbildet gjør det mulig å foreta søk i Datakatalogen etter gitte tekststrenger.

Det kreves spesielle rettigheter for å kunne kjøre denne kommandoen.

Eksempel på utført søk med treff i alle objekttyper

Søket kan gjøres i følgende objekttyper i Datakatalogen:

  • Vegobjekttypekategori
  • Vegobjekttype
  • Egenskapstype
  • Tillatt verdi

Søket skiller ikke mellom små ogs store bokstaver.

Type søk

Det finnes to typer søk:

1 Søk fra starten av

Velges denne type søk vil du få treff bare der starten på et ord er lik med søkestrengen

2 Søk i ord som inneholder

Velges denne type søk vil du få treff uansett hvor i ordet søkestrengen forekommer.

Søk

Søkestrengen

Søkestreng skriver du rett fram. Det spiller ingen rolle om du skriver små eller store bokstaver.

Trykk på [image] når du er klar til å kjøre søket.

Nå søket starter vises dette slik:

Du kan trykke Avbryt søk dersom søket tar for lang tid

Resultat av søket listes i tabellen på skjermen.

Vise detaljer

Du kan dobbeltklikke i hvilken som helst rute i resultattabellen for å få opp detaljskjermbildet for det aktuelle objektet.

Oversikt Type søk Søk Vis detaljer

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Vindu

Menyvalget Vindu åpner for menyvalget Oversikt (tre/liste):

Figuren viser et skjermbilde av menyvalget Vindu.

Menyvalget Vindu/Oversikt vil lukke eventuelle detaljvinduer og bytte til Trestrukturmodus om man står i Listemodus og til Listemodus om man står i Trestrukturmodus.

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Oversikt

Vindu ››

Menyvalget vil lukke eventuelle detaljvinduer og bytte mellom Trestrukturmodus og Listemodus .

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Hjelp

Menyvalget Hjelp åpner for disse menyvalgene:

Figuren viser et skjermbilde av menyvalget Hjelp.

Hjelp Viser denne hjelpeteksten

Symbolforklaring Gir forklaring på en del symboler

Om... Gir informasjon om versjoner og ansvarlige for programmet

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Hjelp

Hjelp ››

Dette menyvalget åpner en hjelpetekst til Datakatalogen. Hjelpeteksten kan også åpnes ved å trykke knappene Ctrl+Shift+F1 på tastaturet.

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Symbolforklaring

Hjelp ››

Her vises symbolforklaring for symboler som er brukt i skjermbildene i DAKAT.

Skjermbildet viser symbolforklaring for DAKAT

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Om

Hjelp ››

Menyvalget Om gir info om versjon av program og Datakatalog, samt hvem som er ansvarlig for utvikling av og brukerstøtte til DAKAT.

Figuren viser Hjelp/Om skjermbildet

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Hjelpefunksjoner

Hjelpefunksjoner er funksjoner som er tilgjengelig i forskjellige skjermbilder. Hjelpefunksjonene fyller to formål:

  • Forenkle bruken av programmet
  • Gi ekstra informasjon

DAKAT har følgende tilgjengelige hjelpefunksjoner for brukere:

Søking i lister

Tooltip

Sortering av lister

Farge/symbolbruk

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Søking i lister

Hjelpefunksjoner ››

Det er laget en hjelpefunksjon for å gjøre det raskt å finne fram til et bestemt valg i ei liste. Dette gjelder generelt for alle listene i programmet.

Det klikkes innenfor den aktuelle lista for å sette denne aktiv, deretter skrives første bokstav i ordet det søkes etter. Første forekomst i lista som starter på denne bokstaven blir dermed satt aktiv. Ved å skrive inn de neste bokstavene vil valgt forekomst i lista stadig nærme seg det en er på jakt etter. Du kan avslutte når du måtte ønske det og så bla videre til du finner det riktige objektet.

Søk i lister. Her er det skrevet SKI for å gå direkte til skiltplate

Skrive 531 for å gå direkte til dette skiltet

Created with the Personal Edition of HelpNDoc: Free EPub producer


Tooltip

Hjelpefunksjoner ››

Ved å holde musemarkøren over et valg i en av listene vil forklaringen vises som ”Tooltip”, dvs. forklaringen vises i et gult felt oppå skjermbildet. Lange forklaringer blir kutta i denne visningen.

Figuren viser eksempel på en Tooltip

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Sortering av lister

Hjelpefunksjoner ››

Alle lister kan sorteres enten alfabetisk eller etter en intern nummerering av feltene:

Figuren viser de to alternative sorteringen av lista

Ved å klikke i feltet over ei liste (overskriften) endres sorteringen av lista. Bak listenavnet står hvilken sortering som gjelder slik lista foreligger.

Created with the Personal Edition of HelpNDoc: Free EPub producer


Farge/symbolbruk

Hjelpefunksjoner ››

Vegobjekttyper, egenskapstyper og tillatte verdier kan ha flere forskjellige status. Dette er markert med fargekoder på symbolet foran objektet i lista eller trestrukturen.

Vegobjekttyper

Grønn farge: Vegobjekttypen er offisiell og i normal bruk

Symbolet viser også at Lekeapparat har geometri av type punkt

Gul farge: Vegobjekttypen er uoffisiell og man kan forvente at den vil bli endret.

Symbolet viser også at Avrettingslag har geometri av type linje/kurve

Egenskaper og tillatte verdier

Rød farge: Egenskapen/tillatt verdi er absolutt påkrevd i NVDB. Egenskapen må gis for å få lov å lagre objektet.

Orange farge: Egenskapen/tillatt verdi er påkrevd. Objektet kan lagres uten at egenskapen er gitt (midlertidig), men registreringen er ikke ferdig før egenskapen er gitt.

Gul farge: Egenskapen/tillatt verdi er betinget. Under gitte forutsetninger er egenskapen påkrevd.

Grønn farge: Egenskapen/tillatt verdi er opsjonell. Det er frivillig å registrere den

Grå farge: Egenskapen/tillatt verdi er på vei ut og har fått tildato i NVDB

Blå farge: Egenskapen/tillatt verdi er lite viktig. Det er frivillig å registrere den.

Sort farge: Egenskapen/tillatt verdi er historisk og vil normalt ikke vises i datakatalogen eller applikasjonene

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Vedlegg – Beskrivelse av attributter

Vedlegget beskriver noen attributter i databasen som inneholder de data som styrer hver attributt sine egenskaper. Det som beskrives her er i hovedsak ment som hjelp for oppsettskjermbildene til Data-menyen.

Følgende objekttyper er beskrevet:

Tema

Vegobjekttypekategorier

Vegobjekttyper

Egenskaptyper

Tillatte verdier

Tillatte sammenhenger

I det følgende er hvert attributt tilhørende skjermbildet/tabellen beskrevet etter følgende mønster.

Navn i skjermbilde

Dette er navnet som brukes som overskrift til feltet i detaljskjermbildet for objekttypen

Populærnavn

Gir populærnavn ("Caption" i databasen) . Inkluderer forstavelse VT for vegobjekttype, ET for egenskapstype, TV for tillatt verdi og TS for tillatt sammenheng osv. I skjermbildet skal det benyttes populærnavn uten forstavelse (Er ikke helt gjennomført).

Attributtnavn

Gir navn som benyttes som attributtnavn i accessbase. Disse navnene benyttes også i programkoden i DAKAT.

NVDB-navn

Gir navn på attributt i NVDB. Eventuell manglende verdi indikerer at attributten ikke er implementert i NVDB. Spørsmålstegn indikerer at det er usikkert om attributten er implementert i NVDB.

Datatype

Angir hvilken Datatype attributten har i Accessbasen.

Krav

Bestemmer om det er krav om at feltet skal ha innhold.

Lovlige verdier

Ja = Feltet skal ha innhold

Nei = Feltet trenger ikke å ha innhold

PK i denne kolonnen betyr at dette feltet er primærnøkkel for tabellen.

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Tema

Vedlegg – Beskrivelse av attributter ››

Denne funksjonen gir beskrivelse av attributter for Tema. Tilpasset visning av tema som vist i skjermbildet under bruker disse attributtene.

Skjermbilde for å tilpasse visning av data for Tema

Feltet Populærnavn i tabellen under brukes i kolonnen Tittel i skjermbildet over. Populærnavn tilsvarer "Caption", altså overskrift i Access-basen.

Feltet Attributtnavn i tabellen brukes i kolonnen Navn i skjermbildet over. Attributtnavn er feltnavn i Access-basen.

Navn i skjermbilde | Populærnavn | Attributtnavn | NVDBnavn | Datatype(lengde) | Krav (Ja/nei)
Id | TM_Id | id_tema |  | Long Integer | PK
Navn | TM_Navn | navn_tema |  | Text (50) | Nei
Beskrivelse | TM_Beskrivelse | beskr_tema |  | Memo | Nei
Kortnavn | TM_Kortnavn | kortn_tema |  | Text (8) | Nei
Nr | TM_Nr | nr_tema |  | Integer | Nei

Beskrivelse av attributter for Tema

Forklaring av feltnavn i tabellen her

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Vegobjekttypekategorier

Vedlegg – Beskrivelse av attributter ››

Denne funksjonen gir beskrivelse av attributter for Vegobjekttypekategorier. Tilpasset visning av vegobjekttypekategorier som vist i skjermbildet under bruker disse attributtene.

Skjermbilde for å tilpasse visning av data for Vegobjekttypekategorier

Feltet Populærnavn i tabellen under brukes i kolonnen Tittel i skjermbildet over. Populærnavn tilsvarer "Caption", altså overskrift i Access-basen.

Feltet Attributtnavn i tabellen brukes i kolonnen Navn i skjermbildet over. Attributtnavn er feltnavn i Access-basen.

Navn i skjermbilde | Populærnavn | Attributtnavn | NVDBnavn | Datatype(lengde) | Krav (Ja/nei)
Vegobjekttype kategori(tall) | VK_Id | ID_VOBJ_TYP_KAT | PeristentObject.PersistentID. | Long Integer | nei
Vegobjekttype kategori(tekst) | VK_Navn | NAVN_VOBJ_TYP_KAT | Nf_Type.name | Text (50) | Nei
Beskrivelse | VK_Beskrivelse | BSKR_VOBJ_TYP_KAT | Nf_Type.description | Memo | Nei
Kortnavn | VK_Kortnavn | kortn_VOBJ_TYP_KAT | Nf_Type.name | Text(8) | Nei
Sorteringsnr | VK_Nr | nr_vobj_typ_kat | Nf_type.no | Integer | Nei
 | VK_Dato_fra | Dato_fra | Nf_FeatureTypeGroup.startDate | Long Integer | Nei
Inngår i tema | VK_Tema | Id_tema | Benyttes til å opprette assosiasjonen til Nf_MainGroup | Long Integer | Ja

Beskrivelse av attributter for Vegobjekttypekategorier

Forklaring av feltnavn i tabellen her

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Vegobjekttyper

Vedlegg – Beskrivelse av attributter ››

Denne funksjonen gir beskrivelse av attributter for Vegobjekttyper. Tilpasset visning av vegobjekttyper som vist i skjermbildet under bruker disse attributtene.

Skjermbilde for å tilpasse visning av data for Vegobjekttyper

Feltet Populærnavn i tabellen under brukes i kolonnen Tittel i skjermbildet over. Populærnavn tilsvarer "Caption", altså overskrift i Access-basen.

Feltet Attributtnavn i tabellen brukes i kolonnen Navn i skjermbildet over. Attributtnavn er feltnavn i Access-basen.

Navn i skjermbilde | Populærnavn | Attributtnavn | NVDBnavn | Datatype(lengde) | Krav (Ja/nei)
Vegobjekttype | VT_Id | ID_VOBJ_TYPE | Nf_PersistentObject.PersistentID | Long Integer | Nei
Navn | VT_Navn | NAVN_VOBJ_TYPE | Nf_Type.name | Text(50) | Nei
Kortnavn | VT_Kortnavn | KORTN_VOBJ_TYPE | Nf_Type.shortname | Text(8) | Ja
Sortering objektliste | VT_Nr | NR_VOBJ_TYPE | Nf_Type.no | Integer | Nei
Beskrivelse | VT_Beskrivelse | BSKR_VOBJ_TYPE | Nf_Type.description | Memo | Nei
Stedfesting | VT_Stedfesting | Stedfesting |  | Text(50) | Nei
Dato fra VDB | VT_Dato_fra | Dato_fra | Nf_FeatureType.startDate | Long Integer | Nei
Dato til VDB | VT_Dato_til | Dato_til | Nf_FeatureType.endDate | Long Integer | Nei
Ajourhold I | VT_Ajh_I | Ajourhold_I | Nn_LocationalAttributeType.update_I | Integer | Nei
Suppleringslengde | VT_Ajh_sl | Ajourhold_supl_lengde |  | Long Integer | Nei
Ajourhold splitt | VT_Ajh_s | Ajourhold_splitt | Nn_LocationalAttributeType.update_divide | Integer | Nei
Dekningsgrad | VT_Dekningsgrad | Dekningsgrad | Nn_LocationalAttributeType.complete | Text(6) | Nei
Filtrering | VT_Filtrering | Filtrering | Nf_FeatureType.filterOn | Yes/No | Nei
Hovedkategori | VT_Hovedkategori | id_hovedkategori | FeatureTypeCategory_enum | Long Integer | Nei
Status | VT_Status | id_status | FeatureTypeState_enum | Long Integer | Nei
Abstrakt objekttype | VT_Abstrakt | abstrakt | Nf_FeatureType.abstract | Yes/No | Nei
Arver fra | VT_Arver_fra | id_arver_fra | Nf_FeatureType.superType (20050714: importeres ikke f.t.) | Long Integer | Nei
Overlapp | VT_Overlapp | Overlapp | Nn_LocationalAttributeType.overLap | Yes/No | Nei
Kjørefelt relevant | VT_Kjf_relevant | KjorefeltRelevant | Nn_LocationalAttributeType.line | Long Integer | Nei
Sidepos. relevant | VT_Sidepos_relevant | SideposisjonRelevant | Nn_LocationalAttributeType.sidePos | Long Integer | Nei
Høyde relevant | VT_Hoyde_relevant | HoydeRelevant | Nn_LocationalAttributeType.heightLevel | Long Integer | Nei
Tidsrom relevant | VT_Tid_relevant | Tidsromrelevant | Nf_FeatureType.timePeriodRelevant. | Yes/No | Nei
 | VT_Aggregeringsregel | Id_Aggregeringsregel | Nf_FeatureType.aggregationRule (string) | Long Integer | Nei
 | VT_Lightversjon | Lightversjon | Nf_FeatureType.simpleVersionOn | Yes/No | Nei
Retning relevant | VT_RetningsRelv | RetningsRelevant | Nn_LocationalAttributeType.dir | Yes/No | Nei
Sek.type2 Ok | VT_Sektype2Ok | Sektype2Ok | ? | Yes/No | Nei
Dato fra NVDB | VT_dato_fra_NVDB | Dato_fra_nvdb | ? | Long Integer | Nei
Flyttbar | VT_Flyttbar | Flyttbar | ? | Yes/No | Nei
Avledet | VT_Avledet | Avledet | ? | Integer | Nei
Veiledning registrering | VT_Instruks | Instruks | pr 20050202 ikke definert | Memo | Nei
Må ha ”mor” | Ma_ha_mor | Ma_ha_mor | 20050714: Ikke definert? | Yes/No | Nei
Dataserie | VT_ Dataserie | Dataserie | ? | Yes/No | Nei
 | VT_Merknad | Merknad | Ikke definert | Memo | Nei
SOSINVDB-navn | SOSINVDB_navn | SOSINVDB_navn | Informasjon overføres ikke til NVDB | Text(50) | Nei
 | Merknad_2 | Merknad_2 | Ikke definert | Text(250) | Nei

Grunnrissreferanse

GrunnrissReferanse

GrunnrissReferanse

Text(255)

Nei

Beskrivelse av attributter for Vegobjekttyper

Forklaring av feltnavn i tabellen her

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Egenskapstyper

Vedlegg – Beskrivelse av attributter ››

Denne funksjonen gir beskrivelse av attributter for Egenskapstyper. Tilpasset visning av egenskapstyper som vist i skjermbildet under bruker disse attributtene.

Skjermbilde for å tilpasse visning av data for Egenskapstyper

Feltet Populærnavn i tabellen under brukes i kolonnen Tittel i skjermbildet over. Populærnavn tilsvarer "Caption", altså overskrift i Access-basen.

Feltet Attributtnavn i tabellen brukes i kolonnen Navn i skjermbildet over. Attributtnavn er feltnavn i Access-basen.

Navn i skjermbilde | Populærnavn | Attributtnavn | NVDBnavn | Datatype(lengde) | Krav (Ja/nei)
Id | ET_Id | ID_EGENSKAPSTYPE | Nf_PersistentObject.PersistentID | Long Integer | PK
Egenskapskategori | ET_Kategori | ID_EG_KAT | Peker til Nf_AttributeTypegroup | Long Integer | Ja
Datatype | ET_Datatype | ID_DATATYPE | Det instansiseres ulike klasser avhengig av hvilken Datatype som er valgt. | Long Integer | Ja
Vegobjekttype | ET_Vegobjekttype | ID_VEGOB_TYPE | Peker til Nf_FeatureType | Long Integer | Nei
Enhet | ET_Enhet | ID_ENHET | Peker til Nf_Unit | Long Integer | Nei
Navn | ET_Navn | NAVN_EGENSKAPSTYPE | Nf_Type.name | Text(50) | Nei
Beskrivelse | ET_Beskrivelse | BSKR_EGENSKAPSTYPE | Nf_Type.description | Memo | Nei
Kortnavn | ET_Kortnavn | KORTN_EGENSKAPSTYPE | Nf_Type.shortName | Text(8) | Nei
Sorteringsnr | ET_Nr | NR_EGENSKAPSTYPE | Nf_Type.no | Integer | Nei
Maksverdi | ET_Maksverdi | RIMELIG_MAXV | Finnes i flere spesialiserte attributtklasser f.eks Nf_IntegerAttributeType.maxValue | Double | Nei
Minverdi | ET_Minverdi | RIMELIG_MINV | Finnes i flere spesialiserte attributtklasser f.eks Nf_IntegerAttributeType.minValue | Double | Nei
Defaultverdi | ET_Defaultverdi | DEFAULTVERDI | Finnes i flere spesialiserte attributtklasser f.eks Nf_IntegerAttributeType.defaultValue | Text (50) | Nei
Desimaler | ET_Antall_desimaler | ANTALL_DESIMALER | Nf_realAttributeType.numbDesimal | Integer | Nei
Total feltelengde | ET_Feltlengde | TOTAL_FELTLENGDE | Finnes i de fleste spesialiserte attributtklasser f.eks Nf_StringAttributeType.TotalFieldLength | Integer | Nei
 | ET_Maske | MASKE | Finnes i de fleste spesialiserte attributtklasser f.eks Nf_StringAttributeType.Format | Text (20) | Nei
Dato fra | ET_Dato_fra | DATO_FRA | NF_PrimitiveAttributeType.startDate og Nf_AssosiationRoleType. startDate | Long Integer | Nei
Dato til | ET_Dato_til | DATO_TIL | NF_PrimitiveAttributeType.endDate og Nf_AssosiationRoleType. endDate | Long Integer | Nei
Ledetekst | ET_Ledetekst | LEDETEKST | Nf_AttributeType.Caption | Text (80) | Nei
Ajourholdt snu | ET_Ajourhold_Snu | Ajourhold_Snu | Nf_primitiveAttributeDate.DirectionSensitive | Yes/No | Nei
OCL_streng | ET_OCL_streng | OCL_streng |  | Memo | Nei
Antall verdier | ET_Antall_verdier | Antall_verdier | Nf_ListAttributeType.MaxNumber | Integer | Nei
Skal ha verdi | ET_Krav | Krav | Nf_AttributeType.Mandatory | Yes/No | Nei
Indekseres | ET_Indekseres | Indekseres | Ikke definert | Yes/No | Nei
Del av egenskapstype | ET_Egenskapstype | id_super_egtype | Nf_StructAttributType | Long Integer | Nei
Dato fra NVDB | ET_Dato_fra_NVDB | Dato_fra_NVDB |  | Long Integer | Nei
Avledet | Avleda | Avleda | pr 20050202 usikker på om impl. i NVDB | Yes/No | Nei
Fortegnsendring v/snu | ET_fortegnsendring | Fortegnsendring | pr 20050202 ikke impl. i NVDB | Yes/No | Nei
TV kortnavn off. | kortnavn_TV_offisiell | kortnavn_TV_offisiell | pr 20050202 ikke impl. i NVDB | Yes/No | Nei
Maks lengde | kortnavn_TV_lengde | kortnavn_TV_lengde | pr 20050202 ikke impl. i NVDB | Integer | Nei
Absolutt Minverdi | Absolutt_min | Absolutt_min | pr20050311 ikke impl. i NVDB | Double | Nei
Absolutt Maksverdi | Absolutt_maks | Absolutt_maks | pr20050311 ikke impl. i NVDB | Double | Nei
Lengdeavhengig verdi | ET_Lengdeahengig | Lengdeavhengig_verdi | Ikke definert | Yes/No | Nei
 | Identisk_med | Identisk_med |  | Long Integer | Nei
 | Merknad | Merknad | Overføres ikke til NVDB | Text (250) | Nei
Sensitivitet | Sensitivitetskategori | Sensitivitetskategori |  | Text(3) | Nei

SOSINVDB-navn

SOSINVDB_navn

SOSINVDB_navn

Text (50)

Nei

Viktighet

Viktighet

Viktighet

Integer

Nei

Merknad registrering

Merknad_registrering

Merknad_registrering

Memo

Nei

Beskrivelse av attributter for Egenskapstyper

Forklaring av feltnavn i tabellen her

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Tillatte verdier

Vedlegg – Beskrivelse av attributter ››

Denne funksjonen gir beskrivelse av attributter for Tillatte verdier. Tilpasset visning av tillatte verdier som vist i skjermbildet under bruker disse attributtene.

Skjermbilde for å tilpasse visning av data for Tillatte verdier

Feltet Populærnavn i tabellen under brukes i kolonnen Tittel i skjermbildet over. Populærnavn tilsvarer "Caption", altså overskrift i Access-basen.

Feltet Attributtnavn i tabellen brukes i kolonnen Navn i skjermbildet over. Attributtnavn er feltnavn i Access-basen.

Navn i skjermbilde | Populærnavn | Attributtnavn | NVDBnavn | Datatype(lengde) | Krav (Ja/nei)
 | TV_Id | ID_TILLATT_VERDI | PersistentObject.persistentID | Long Integer | PK
Egenskapstype | TV_Egenskapstype | ID_EGENSKAPSTYPE |  | Long Integer | Ja
Navn | TV_Navn | NAVN_TILLATT_VERDI | Nf_EnumStringAttribute.value | Text (100) | Ja
Beskrivelse | TV_Beskrivelse | BSKR_TILLATT_VERDI | Ikke definert | Memo | Nei
Sorteringsnr | TV_Nr | NR_TILLATT_VERDI | Nf_Constraint.no | Integer | Nei
Kortnavn | TV_Kortnavn | KORTN_TILLATT_VERDI | Nf_EnumPrimitive.shortValue | Text (8) | Nei
Fra dato | TV_Dato_fra | dato_fra | Nf_Constraint.startDate | Long Integer | Nei
Til dato | TV_Dato_til | dato_til | Nf_Constraint.endDate | Long Integer | Nei
 | TV_Illustrasjon | id_figur | Rolle til Nf_illustration | Long Integer | Nei
Std.verdi | TV_Defaultverdi | Defaultverdi | Nf_EnumPrimitive.defaultEnum | Yes/No | Nei
Dato fra NVDB | TV_dato_fra_nvdb | Dato_fra_nvdb | ? | Long Integer | Nei
 | TV_Merknad | Merknad | Ikke definert | Memo | Nei

Beskrivelse av attributter for Tillatte verdier

Forklaring av feltnavn i tabellen her

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Tillatte sammenhenger

Vedlegg – Beskrivelse av attributter ››

Denne funksjonen gir beskrivelse av attributter for tillatte sammenhenger. Tilpasset visning av tillatte sammenhenger som vist i skjermbildet under bruker disse attributtene.

Skjermbilde for å tilpasse visning av data for Tillatte sammenhenger

Feltet Populærnavn i tabellen under brukes i kolonnen Tittel i skjermbildet over. Populærnavn tilsvarer "Caption", altså overskrift i Access-basen.

Feltet Attributtnavn i tabellen brukes i kolonnen Navn i skjermbildet over. Attributtnavn er feltnavn i Access-basen.

Navn i skjermbilde | Populærnavn | Attributtnavn | NVDBnavn | Datatype(lengde) | Krav (Ja/nei)
 | TS_Id | ID_TILLATT_SAMMENHENG | PersistentObjekt.PersistentID | Long Integer | PK
Sammenheng(tall) | TS_Sammenhengtype | ID_SAMMENHENGTYPE | ENUM Affiliation | Long Integer | Ja
Type A | TS_Vegobjekttype_A | VOBJ_TYP_A | TS omsettes til attributt/ET tilhørende VT angitt her. | Long Integer | Ja
Type B | TS_Vegojekttype_B | VOBJ_TYP_B | Peker til Nf_FeatureType | Long Integer | Ja
Ledetekst | TS_Ledetekst | Ledetekst | Nf_AttributeType.Caption | Text (80) | Nei
Dato fra | TS_Dato_fra | dato_fra | Nf_AssosiationRoleType.startDate | Long Integer | Nei
Dato til | TS_Dato_til | dato_til | Nf_AssosiationRoleType.endDate | Long Integer | Nei
Rollenavn AB | TS_RollenavnAB | RollenavnAB | Nf_Type.name | Text (50) | Nei
B slettes hvis A slettes | TS_EierAB | EierAB |  | Yes/No | Nei
Beskrivelse | TS_Beskrivelse | beskr_tillatt_sammenheng | Nf_Type.description | Memo | Nei
Maks antall | TS_Maks_antall | Maks_antall | maxNumber | Long Integer | Nei
Dato fra NVDB | TS_Dato_fra_NVDB | Dato_fra_NVDB | ? | Long Integer | Nei
Sted B innenfor A | TS_Sted_B_innenfor_A | Sted_B_innenfor_A | pr 20050202 ikke impl. i NVDB | Text (50) | Nei
Min. antall | TS_Min_antall_AB | Min_antall | ? | Text (50) | Nei

Beskrivelse av attributter for Tillatte sammenhenger

Forklaring av feltnavn i tabellen her

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Eksempler

Dette kapitlet viser en del eksempler som ikke passer direkte inn i de tidligere kapitler

Eksempel på UML-skjema

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Eksempel på UML-skjema

Eksempler ››

UML står for Unified Modeling language og er en industristandard for datarelatert modellering. UML beskriver en rekke forskjellige typer diagrammer. I produktspesifikasjonene brukes klassediagrammer som det er vist et eksempel på her:

UML-skjema for skiltplate

Klassediagrammet inneholder et stort antall opplysninger:

  • Alle egenskaper gitt ved navn
  • Datatype for alle egenskaper
  • Kardinalitet, dvs. om egenskapen er opsjonell, påkrevd og eventuelt kan ha mer enn en verdi.
  • Tillatte verdier for de egenskaper som har dette
  • Relasjon mellom flere vegobjekttyper

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator